WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#3306 closed defect (bug) (worksforme)

saving post takes me to the wrong page

Reported by: lschiere Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Administration Keywords:
Focuses: Cc:

Description

Since upgrading to wordpress 2.0.5, when I publish a post or save a published post, I get taken to www.schierer.org even though wordpress is installed and hosted from www.schierer.org/~luke/log. This was not a problem in 2.0.4. Please let me know what if any additional information you need to track down this regression.

Change History (6)

comment:1 foolswisdom7 years ago

Thanks for reporting this problem lschiere -- a friend of gaim is a friend of mine. So far I have not been able to reproduce it.

By "taken to", does that mean when you click Publish, there is then a link at the top which you click? Hovering over that link its URL is www.schierer.org ?

I notice you have an interesting permalink structure.

WordPress address (URI) and Blog address (URI) are?

"Also include information about your platform, such as operating system, web server software, PHP version, MySQL version etc."
http://codex.wordpress.org/Reporting_Bugs#Reporting_your_bug

What are the plugins you have installed?

comment:2 lschiere7 years ago

both the wordpress address and blog address are set to http://www.schierer.org/~luke/log

I'm on a debian system (a mix of sarge and etch, mostly sarge) with Apache 2.0.54-5sarge1 using the prefork mpm. I've php4 4.3.10-16, the stand alone package, not the cgi one. mysql is at version 4.1.11a-4sarge7

Plugins installed:
ajax spell checker, not active.
akismet, not active
hello dolly, not active
Live+Press, not active
LiveJournal Corss poster 1.5 active
Markdown 1.0.1 not active
php markdown extra 1.0.1 active
spelling checker 1.18 active
subscribe to comments active
textile 1 not active
witty text 1.1 active
Wordpress database backup 1.8 active
wp-cache not active

When I hover the mouse over the publish button, it does not show any tooltip or info in the status bar to indicate where it will take me. When I press it, to publish the post, the browser spends some time waiting for a responce. I expect that, it has done so since I first loaded the LJ cross post plugin.

What is unexpected is that when the next page starts to load it is http://www.schierer.org when I would expect it to be the write page confirming the fact that I just posted, or at least some page with a url starting with http://www.schierer.org/~luke/log/wp-admin/

I have posted twice today, and edited 3 posts today, and each time, pressing publish or save (respectively) has caused me to end up at http://www.schierer.org/ and to need to navigate back to www.schierer.org/~luke/log to verify that my change did in fact get saved. It had, so the database saving is working correctly, it is just the target of the form that is somehow wrong.

The permalink structure has not changed since shortly after I first installed wordpress, in June of 2005. I chose it to most closely match the homegrown stuff I had been using before wordpress.

I'd love to fill in more of the values here in the trac ticket properties, but 2.0.5 is not available as a version, and the defaults seem fine for the rest. Sorry for not including the version information in my first post.

comment:3 lschiere7 years ago

Apparently my formatting was not fully preserved, so the list of plugins is not particularly readable.

ajax spell checker, not active.

akismet, not active

hello dolly, not active

Live+Press, not active

LiveJournal? Cross poster 1.5 active

Markdown 1.0.1 not active

php markdown extra 1.0.1 active

spelling checker 1.18 active

subscribe to comments active

textile 1 not active

witty text 1.1 active

Wordpress database backup 1.8 active

wp-cache not active

comment:4 lschiere7 years ago

Is any additional information needed here?

comment:5 lschiere7 years ago

  • Cc luke-wordpress@… added

comment:6 lschiere7 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

this has randomly disappeared without me having changed anything. Very odd.

Note: See TracTickets for help on using tickets.