WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#33076 closed enhancement (duplicate)

rewrite get_adjacent_post in terms by using wp_query instead of hand written queries

Reported by: mark-k Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.7
Component: Posts, Post Types Keywords:
Focuses: Cc:
PR Number:

Description

The reason for looking at that code is to find a way to ignore posts with some specific values in meta, something that became almost trivial to do when using wp_query.

If I get it right the changes done in wp_query in 3.7+ make it possible to use wp_query to find the next and previous posts.

Change History (2)

#1 @boonebgorges
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #26937.

#2 @SergeyBiryukov
4 years ago

  • Component changed from General to Posts, Post Types
Note: See TracTickets for help on using tickets.