Make WordPress Core

Opened 9 years ago

Closed 8 years ago

#33104 closed defect (bug) (worksforme)

Redirect Loop when enabling/disabling a theme on multisite

Reported by: hube2's profile Hube2 Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.2.3
Component: Networks and Sites Keywords:
Focuses: multisite Cc:

Description

Hopefully this has not already been reported, I tried searching for something on this and was unable to find anything.

On network admin themes /wp-admin/network/themes.php when you click on Network Enable or Network Disable there is an infinite redirect loop error.

Looking at the above file, this is caused because the "action" query argument is not being removed from the URL causing the enable or disable action to replay over and over again.

Change History (9)

#1 @Hube2
9 years ago

  • Keywords close added
  • Resolution set to invalid
  • Status changed from new to closed

As suddenly as this appeared the problem seems to have gone away and I didn't change anything. Very odd.

#2 @SergeyBiryukov
9 years ago

  • Keywords close removed
  • Milestone Awaiting Review deleted

#3 @SergeyBiryukov
9 years ago

  • Summary changed from Redirect Loop when enabling/disabling a them on multisite to Redirect Loop when enabling/disabling a theme on multisite

#4 follow-up: @Hube2
9 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

I don't know what's going on with this, but the issue is back as described. I was testing to see if I could clear up the problem and it could be that the server had cached the code. At any rate, this is an issue.

Sorry for any confusion.

#5 @SergeyBiryukov
9 years ago

  • Milestone set to Awaiting Review

#6 @danielwrobert
8 years ago

I am also seeing this issue. In the Network Admin on a multisite installation, the “Network Enable” link in the list table row doesn’t work. When you attempt to Network Enable a theme via this link, you are directed to a page that displays the following message:

Are you sure you want to do this?
Please try again.

See screenshot: https://cloudup.com/cWMPvw-XXVG

You can, however, network enable themes via the Bulk Actions dropdown option.

#7 in reply to: ↑ 4 @jeremyfelt
8 years ago

  • Keywords reporter-feedback added

Replying to Hube2:

I don't know what's going on with this, but the issue is back as described. I was testing to see if I could clear up the problem and it could be that the server had cached the code. At any rate, this is an issue.

Can you provide more details on your configuration. Is this a subdomain or subdirectory configuration of multisite? Do you have a domain mapping plugin installed? Are you able to reproduce this without any plugins activated?

I'm currently testing in a subdirectory configuration and seeing no issues. Looking at the code, I'm not sure how a redirect loop could happen here unless a URL is being filtered.

Replying to danielwrobert:

I am also seeing this issue. In the Network Admin on a multisite installation, the “Network Enable” link in the list table row doesn’t work. When you attempt to Network Enable a theme via this link, you are directed to a page that displays the following message:

Are you sure you want to do this?
Please try again.

This message will be shown via check_admin_referer() if the nonce attached to the link is no longer valid. It seems unrelated to the redirect issue described in the original ticket here.

#8 @Hube2
8 years ago

I just tested this on the site where I was experiencing the problem and the problem seems to have gone away, or at least it is no longer timing out when activating and deactivating themes.

The site has had WP updated since this report, so maybe that had something to do with it.

More information on the site as it was at the time of the problem
WP Version 4.2.3
Configuration: Subdomain
Domain mapping plugin: No

Since it's not happening now it seems to have been corrected. This can be closed as far as I'm concerned it the others that reported it are no longer seeing a problem.

#9 @SergeyBiryukov
8 years ago

  • Keywords reporter-feedback removed
  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from reopened to closed

@Hube2, thanks for the follow-up.

Note: See TracTickets for help on using tickets.