WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#33125 closed feature request (duplicate)

Reserved terms

Reported by: jmlapam Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.3
Component: Posts, Post Types Keywords:
Focuses: Cc:

Description

Hi, I know there's a list of reserved terms here : https://codex.wordpress.org/Reserved_Terms

The problem is if I don't know this page I can break all the thing easily.

If one uses e.g keyword "action" as slug for a custom post type which is not in the current list of reserved terms, you get strange bugs. I mean site do not break, you can even regrister taxonomies on this post type but requests in admin might break. For example, search in post listings is no longer possible.

It could be safer to trigger an error. The caveat is that a list of reserved terms must be set in code so more maintenance...

What do you think about it ?

Change History (1)

#1 @SergeyBiryukov
6 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #31154.

Note: See TracTickets for help on using tickets.