WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#33138 closed defect (bug) (fixed)

Customizer on mobile: fixed grey space at the bottom

Reported by: iseulde Owned by: westonruter
Milestone: 4.3 Priority: normal
Severity: normal Version: 4.3
Component: Customize Keywords: has-patch commit
Focuses: Cc:
PR Number:

Description


Attachments (5)

IMG_3367.PNG (810.3 KB) - added by iseulde 4 years ago.
33138.diff (624 bytes) - added by obenland 4 years ago.
33138.2.diff (1.1 KB) - added by obenland 4 years ago.
33138.3.diff (1.1 KB) - added by westonruter 4 years ago.
33138.4.diff (1.1 KB) - added by westonruter 4 years ago.

Download all attachments as: .zip

Change History (19)

@iseulde
4 years ago

#1 @iseulde
4 years ago

  • Milestone changed from Future Release to 4.3
  • Version set to trunk

Don't remember seeing this in 4.2.

#2 @obenland
4 years ago

  • Owner set to westonruter
  • Status changed from new to assigned

#3 @obenland
4 years ago

Something is setting the wrong height there

Last edited 4 years ago by markjaquith (previous) (diff)

#4 @obenland
4 years ago

Introduced in [33069].

@obenland
4 years ago

#5 @obenland
4 years ago

  • Owner changed from westonruter to ocean90

#6 @obenland
4 years ago

  • Keywords has-patch added; needs-patch removed

@ celloexpressions, could you review if that patch is in line with what was intended in [33069]?

#7 @ocean90
4 years ago

  • Keywords needs-patch added; has-patch removed

It's content.css( 'height', ( window.innerHeight - 90 ) ); which needs to be removed/changed for screen sizes below 640px IMO.

#8 @celloexpressions
4 years ago

90 is derived from 45px for the header and 45px for the footer, which is only shown on larger screens. New patch needs to check for screen size < 640px and use 45 instead of 90 in those cases, and should also add inline comments explaining where the magic numbers come from. I've been trying to avoid setting the height in JS like this since panels were first introduced a year ago, but it's just necessary and going to make things easier moving forward to do it this way.

#9 @obenland
4 years ago

@celloexpressions would you mind creating that patch?

#10 @celloexpressions
4 years ago

I likely won't have time until after RC, but I could do it then (assuming it's still tracking Wednesday). Should be a fairly straightforward patch.

@obenland
4 years ago

#11 @obenland
4 years ago

  • Keywords has-patch added; needs-patch removed

@westonruter
4 years ago

@westonruter
4 years ago

#12 @westonruter
4 years ago

  • Keywords commit added

#13 @obenland
4 years ago

  • Owner changed from ocean90 to westonruter

#14 @westonruter
4 years ago

  • Resolution set to fixed
  • Status changed from assigned to closed

In 33454:

Customizer: Hide empty space in footer on small screens since it is only populated on larger screens.

Props obenland.
Fixes #33138.

Note: See TracTickets for help on using tickets.