WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#33164 closed defect (bug) (fixed)

New password UI on user profile - hide button shows wrong state

Reported by: knutsp Owned by: markjaquith
Milestone: 4.3 Priority: normal
Severity: minor Version: 4.3
Component: Administration Keywords:
Focuses: javascript Cc:

Description

Steps to reproduce in profile.php:

  1. Click "Generate password"
  2. Click "Hide" (the important step here)
  3. Click "Cancel"
  4. Click "Generate password" (again)

Expected, either

  1. Password is hidden and button says "Show"
  2. Password is shown and button says "Hide"

Actual:

  • Password is shown and button says "Show"
  • When clicking "Show" nothing happens (at this time expected, though)

Conclusion: When "Cancel" is activated the state of both the password field and the show/hide button should be preserved, or both should return to their default states.

4.3-beta4-33468

Attachments (1)

33164.png (9.1 KB) - added by knutsp 6 years ago.

Download all attachments as: .zip

Change History (6)

@knutsp
6 years ago

#1 @knutsp
6 years ago

  • Keywords needs-patch added
  • Severity changed from normal to minor
  • Summary changed from New password UI on user profile - hide button show wrong state to New password UI on user profile - hide button shows wrong state

#2 @knutsp
6 years ago

After some thought: I would absolutely prefer the "hidden" state to persist and not returning to the default state (showing).

#3 @SergeyBiryukov
6 years ago

  • Milestone changed from Awaiting Review to 4.3

#4 @markjaquith
6 years ago

  • Owner set to markjaquith
  • Resolution set to fixed
  • Status changed from new to closed

In 33475:

Do not re-generate the password after pressing "cancel". Persist the state.

Also removes pass2 code not needed since we're generating from one field.

fixes #33164

#5 @knutsp
6 years ago

  • Keywords needs-patch removed
Note: See TracTickets for help on using tickets.