Make WordPress Core

Opened 9 years ago

Closed 9 years ago

#33194 closed enhancement (duplicate)

Enable option to delete database entries upon plugin uninstall

Reported by: anonymized_14235950's profile anonymized_14235950 Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.2.3
Component: General Keywords:
Focuses: administration, performance Cc:

Description

I've noticed that plugins often leave database entries behind even after uninstalling. I know that some do it for good reasons, but I think that users should have an easy way to delete them. I try out a lot of plugins and I don't want all their old data collecting in the database and sitting there for all of infinity.

I think WordPress should do one or both of the following:

  1. Have an option to delete all the plugin's database entries when uninstalling, along with a message from the plugin author saying why that might be a bad idea.
  1. Have an options in settings which shows a list of the plugins which have entries stored in the database, even if those plugins have already been uninstalled. Then users could retroactively go in and delete the entries if they decide they won't ever use the plugins again.

Change History (1)

#1 @netweb
9 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #26945.

Note: See TracTickets for help on using tickets.