WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#33197 closed defect (bug) (duplicate)

Upgrading on 4.3 - Could not Establish Secure Connection to Wordpress.org

Reported by: atomicjack Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.3
Component: Upgrade/Install Keywords:
Focuses: Cc:
PR Number:

Description

Just set-up the beta version, and clicked Update to the nightly build, but it keeps saying it cannot establish a secure connection to Wordpress.org even though, non-4.3 sites update fine.

Downloading update from https://wordpress.org/nightly-builds/wordpress-latest.zip…

Unpacking the update…

Verifying the unpacked files…

Preparing to install the latest version…

Warning: An unexpected error occurred. Something may be wrong with WordPress.org or this server’s configuration. If you continue to have problems, please try the support forums. (WordPress could not establish a secure connection to WordPress.org. Please contact your server administrator.) in -hidden-/wp-admin/includes/update.php on line 115
Enabling Maintenance mode…

Copying the required files…

Disabling Maintenance mode…}}}

Change History (7)

#1 follow-up: @dd32
4 years ago

Can you duplicate this reliably?

This warning is usually (almost always) caused by a HTTP timeout, which can happen easily if it's setup locally.

#2 in reply to: ↑ 1 @atomicjack
4 years ago

Replying to dd32:

Can you duplicate this reliably?

This warning is usually (almost always) caused by a HTTP timeout, which can happen easily if it's setup locally.

I have no other means of testing it in any other environment at the moment, however, multiple other WordPress installations are also run locally, and they all update perfectly. It's just this RC doesn't want too.

#3 @atomicjack
4 years ago

I just ran the update for a 5th time - and it was successful, no errors.

It seems it could be an issue with wordpress.org or something, as nothing changed on my local set-up.

#4 @dd32
4 years ago

Sounds like a network timeout then, the timeout on that request is probably the default 3 seconds, it can probably be increased..

#5 @atomicjack
4 years ago

Is this correct section of code?

if ( $c <= 50 || ( $c > 50 && mt_rand( 0, (int)( $c / 50 ) ) == 1 ) ) {
			require_once( ABSPATH . WPINC . '/http.php' );
			$response = wp_remote_get( admin_url( 'upgrade.php?step=1' ), array( 'timeout' => 120, 'httpversion' => '1.1' ) );
			/** This action is documented in wp-admin/network/upgrade.php */
			do_action( 'after_mu_upgrade', $response );
			unset($response);
		}
		unset($c);
	}
}

#6 @atomicjack
4 years ago

Seems to happen even when not updating.

Warning: An unexpected error occurred. Something may be wrong with WordPress.org or this server’s configuration. If you continue to have problems, please try the support forums. (WordPress could not establish a secure connection to WordPress.org. Please contact your server administrator.) in -hidden-/wp-includes/update.php on line 122

It appeared at the top of the Updates page, whilst having the force-check set to 1 on the URL attributes.

#7 @SergeyBiryukov
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #27722.

Note: See TracTickets for help on using tickets.