WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#33231 closed feature request (maybelater)

Stars for Featured Posts

Reported by: freetheweb Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.2.3
Component: Posts, Post Types Keywords:
Focuses: administration Cc:

Description

The idea of separating "featured" posts from normal posts has become incredibly popular, and done by so many sites that I believe WordPress should add a special "featured" functionality for featured post types. "Featured" posts should not be just another category for several reasons. Using one category for "featured" posts is a workaround which present problems for users down the line. If they want to list their categories for readers to view, they might have to find a way to list all categories and exempt "featured" from that list. This also breaks functionality in some other applications and plugins.

Thinking about what "featured" posts actually are, what it means to be "featured," it is clear to me that it should not be grouped together with every other post category. Many other services acknowledge this, and WordPress should as well.

I believe WordPress featured posts should work like Gmail emails: normal posts look like they currently do. Featured posts would have a star to the left of the title. Click the star and it automatically becomes "featured."

Acknowledging that featured posts are becoming so ubiquitous and treating them differently from categories would alleviate many problems caused by using categories as a workaround. Also, it would not be necessary to even call them "featured." They could be called "starred" posts, and the user could set the title of what to call them that fits their site's purpose best. This would even avoid it feeling like a workaround for their site at all.

Change History (1)

#1 @DrewAPicture
5 years ago

  • Focuses administration added
  • Milestone Awaiting Review deleted
  • Resolution set to maybelater
  • Status changed from new to closed

My initial thought here is whether this would be something that 80 percent of the userbase would find useful. My second thought is that there would need to be careful consideration about how this might clash at a conceptual level with the stickies. Would this only be for posts? All post types?

I think is an interesting idea, but one that squarely falls into plugin territory at this juncture. There are definitely some unanswered questions. If a need can be demonstrated via plugin adoption, that's when it would be a good time to return to this discussion.

Closing as maybelater. Feel free to continue the discussion here if you like.

Note: See TracTickets for help on using tickets.