WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#33236 closed enhancement (invalid)

Hovering over a menu item or clicking outside the distraction-free disables the mode on the Title

Reported by: stuartshields Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.1
Component: Editor Keywords: close
Focuses: ui, administration Cc:

Description

To reproduce

  1. Put Post or Page into distraction-free mode everything disappears except for the Title and Editor
  2. Click anywhere but the Title or Visual editor, everything re-appears as it's meant to (you can also hover over a menu item as it does the same thing.
  3. Now place cursor inside of the Title box, distraction-free mode doesn't re-enable itself automatically like it does when the cursor is placed in the Visual editor

This was tested in Firefox 41 and Chrome Chrome 44

Results
Clicking anywhere disables the distraction-free mode for the Title box, to re-enable it you need to click the Visual editor and back onto the Title box

Expected result
Like the Editor, clicking the Title box should re-enable distraction-free mode.

Attachments (2)

Screen Shot 2015-08-03 at 2.39.45 pm.png (29.9 KB) - added by stuartshields 5 years ago.
Distraction-free mode is enabled with the title and visual editor showing
Screen Shot 2015-08-03 at 2.40.03 pm.png (42.8 KB) - added by stuartshields 5 years ago.
Hovering over a menu item, or clicking outside the distraction-free area disabled it on the Title box.

Download all attachments as: .zip

Change History (4)

@stuartshields
5 years ago

Distraction-free mode is enabled with the title and visual editor showing

@stuartshields
5 years ago

Hovering over a menu item, or clicking outside the distraction-free area disabled it on the Title box.

#1 @iseulde
5 years ago

  • Component changed from Administration to Editor
  • Keywords close added
  • Type changed from defect (bug) to enhancement
  • Version changed from trunk to 4.1

This is intentional. Typing the title will never trigger DFW. It's been like this since we added it to core.

See https://github.com/iseulde/focus/issues/28.

Cc @markjaquith.

#2 @wonderboymusic
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.