WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#33243 closed defect (bug) (worksforme)

Attaching media files - bad user experience

Reported by: pavelevap Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Media Keywords:
Focuses: Cc:

Description

  • Go to Media Library (list view)
  • Select "Unattached" in dropdown
  • Column "Uploaded to" disappears

It is not possible to reattach some older media files and I have to search for them in Media library. So "Unattached" option in dropdown is almost useless...

I did not find any was how to attach or dettach media files in grid view?

Attachments (1)

33243.png (66.2 KB) - added by ocean90 5 years ago.

Download all attachments as: .zip

Change History (4)

@ocean90
5 years ago

#1 @ocean90
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed
  • Version trunk deleted

There is an action link "Attach", see 33243.png.

This ticket was mentioned in Slack in #core by obenland. View the logs.


5 years ago

#3 @pavelevap
5 years ago

Now I see it :-)

I did not notice this hidden link and I do not believe that anybody does. It is unexpected change (missing column) when you select "Unattached". Also when you are in "Unattached" part and attach some file, then this file disappears (it is no longer "Unattached"). I understand that it has some logic, but you should try to attach several hundreds media files, it is not very user friendly. You would like to see which (previously unattached) file was attached to which content, etc.

Note: See TracTickets for help on using tickets.