WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#33244 closed defect (bug) (duplicate)

Update notice does not disappear (Changed site language to Deutsch (Sie))

Reported by: La Geek Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.2.3
Component: I18N Keywords:
Focuses: Cc:

Description

How to reproduce:
Change language size to "Deutsch (Sie)". You will get an update notice for the language files. Click on update. You can do this as often as you like, the update notice is still in the adminbar.

Ps: In beta version 4.3. this works without issues.

Change History (4)

#1 @ocean90
6 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #28303.

This is fixed in [33027]. Only WordPress 4.3+ is supporting variants of languages.

#2 @markoheijnen
6 years ago

Then the API would be broken right? As it shouldn't have returned Deutsch (Sie).

#3 @La Geek
6 years ago

  • Keywords reporter-feedback added
  • Resolution duplicate deleted
  • Status changed from closed to reopened

Now there exists some confusion about this. I wrote the article on de.wordpress.org about the variants of languages (this article you know @ocean90). I wrote, this feature will be available in WP 4.3.

In the comments a user mentioned, that the option to choose "Deutsch (Sie)" exists at least since WP version 4.2.2.

@zodiak1978 (Torsten) commented, that the option to choose a language is available since v. 4.0. In addition the function "variants of languages" has been enabled on server site 3 weeks ago (https://core.trac.wordpress.org/ticket/28303).

So I changed the article regarding these new informations.

In summary:
You can choose the language since version 4.0
You can choose Deutsch (Sie) since 3 weeks.

And now wrote Dominik, that
only WordPress 4.3 supports variants of languages?

Why we can choose Deutsch (Sie) in versions prior 4.3?
Something is definitively wrong.

I would be delighted to get some clarification :) , thank you.

#4 @ocean90
6 years ago

  • Keywords reporter-feedback removed
  • Resolution set to duplicate
  • Status changed from reopened to closed

I'll disable pushing de_DE_formal for WordPress < 4.3.

Note: See TracTickets for help on using tickets.