WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#33268 closed defect (bug) (fixed)

The inline toolbars (image, wpView, link) show above the wplink modal backdrop

Reported by: azaozz Owned by: azaozz
Milestone: 4.3 Priority: normal
Severity: normal Version: 4.3
Component: TinyMCE Keywords: has-patch commit
Focuses: Cc:

Description

Seems the wpLink modal triggers another editor.nodeChange() after it is opened/shown. That shows the floating toolbar as the right element is selected in the editor.

As the wpLink backdrop is added to the DOM before the inliine toolbar, and they have the same z-index, the toolbar is shown above the backdrop.

Attachments (2)

link-toolbar.png (15.0 KB) - added by azaozz 6 years ago.
33268.patch (758 bytes) - added by azaozz 6 years ago.

Download all attachments as: .zip

Change History (12)

@azaozz
6 years ago

#1 @azaozz
6 years ago

We can increase the z-index on the wpLink modal and backdrop, however that doesn't seem to work in iOS and older IE. The other option is to always move the modal to be the last child in the body.

@azaozz
6 years ago

#2 @azaozz
6 years ago

  • Milestone changed from Awaiting Review to 4.3

In 33268.patch: ensure the backdrop and the modal are the last nodes in the body.

#3 @obenland
6 years ago

  • Owner set to azaozz
  • Status changed from new to assigned

#4 @obenland
6 years ago

@iseulde, could you review the patch when you get a chance?

#5 @iseulde
6 years ago

I cannot reproduce this bug. :/

This ticket was mentioned in Slack in #core by azaozz. View the logs.


6 years ago

#7 @afercia
6 years ago

Can reproduce the bug on both latest Chrome and Firefox on Windows:
https://cldup.com/iY2JY7m-37.png
and the patch fixes it for me.

Last edited 6 years ago by afercia (previous) (diff)

This ticket was mentioned in Slack in #core by azaozz. View the logs.


6 years ago

#9 @SergeyBiryukov
6 years ago

  • Keywords has-patch commit added

Reproduced the bug in Firefox 39 on Windows.

33268.patch works as expected.

#10 @SergeyBiryukov
6 years ago

  • Resolution set to fixed
  • Status changed from assigned to closed

In 33588:

wpLink: Make sure the link wrapper is the last element in the body, otherwise the inline editor toolbar may show up above the backdrop.

props azaozz.
fixes #33268.

Note: See TracTickets for help on using tickets.