WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#33328 closed defect (bug) (duplicate)

Retrieve password message fail when sending html messages

Reported by: timersys Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.3
Component: General Keywords:
Focuses: Cc:

Description

When you set up your WordPress to send HTML templates the reset password link fails on almost every email client.

The solution is simple to remove "<" and ">" from the link in

$message .= '<' . network_site_url("wp-login.php?action=rp&key=$key&login=" . rawurlencode($user_login), 'login') . ">\r\n";

Attachments (1)

patch.33328.diff (746 bytes) - added by timersys 5 years ago.

Download all attachments as: .zip

Change History (10)

#1 @obenland
5 years ago

  • Milestone changed from Awaiting Review to 4.3
  • Owner set to markjaquith
  • Status changed from new to reviewing

@markjaquith do you have time to investigate that?

@timersys
5 years ago

#2 @obenland
5 years ago

Introduced in [16285] for #14140.

#3 @timersys
5 years ago

It seems that is more related to #23578 . I knew that those brackets were there for a reason, I just couldn't find it

Last edited 5 years ago by SergeyBiryukov (previous) (diff)

#4 @ocean90
5 years ago

Related/duplicate: #23420, #21095

#5 @ocean90
5 years ago

  • Focuses accessibility removed

#6 @obenland
5 years ago

This might not be something we need to fix in 4.3 then.

#7 @timersys
5 years ago

The patch provided in #23578 is simple and effective and it was submitted 2 years ago.... wrapping emails in nice html templates it's pretty common nowadays. While this is not urgent / critical, I don't think implementing that patch this will take more time than reading my messages :)

Thanks!

Last edited 5 years ago by SergeyBiryukov (previous) (diff)

#8 @obenland
5 years ago

  • Milestone changed from 4.3 to Awaiting Review
  • Owner markjaquith deleted

#9 @SergeyBiryukov
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from reviewing to closed

Duplicate of #23578.

Note: See TracTickets for help on using tickets.