Make WordPress Core

Opened 9 years ago

Closed 6 years ago

#33343 closed defect (bug) (worksforme)

Insert/edit link modal text overlaps if title is long. Also should be re-sizable.

Reported by: b-rad's profile b-rad Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.0
Component: Editor Keywords:
Focuses: ui, administration Cc:

Description

When the title of a page/post is long, the Insert/Edit Link Window overlaps the title with the content type (see first link list row in image below):

http://i.imgur.com/OcAmJMa.gif

I noticed this when adding a custom post type which is longer then the usual "page" or "post" text in the second column.

In terms of styling, I propose the the absolute positioning be removed and the spans that make up these rows be changed to display:table-cell.

Also, this modal should be draggable and re-sizable.

Change History (2)

#1 @azaozz
8 years ago

  • Milestone changed from Awaiting Review to Future Release
  • Version changed from 4.2.4 to 4.0

Don't think the modal should be draggable and re-sizable. That usually interferes with it being responsive. Agreed that the URL list looks like tabular data. It should have probably been a table.

I'm tempted to close this in favor of #33301, but since there is no timeline for it perhaps we can add it when a patch is available.

#2 @antpb
6 years ago

  • Milestone Future Release deleted
  • Resolution set to worksforme
  • Status changed from new to closed

This looks to be fixed now as mentioned above. I've confirmed with screenshot below in latest Chrome. Closing :)

http://www.antpb.com/wp-content/uploads/2018/06/33343.png

Note: See TracTickets for help on using tickets.