Make WordPress Core

Opened 9 years ago

Closed 9 years ago

Last modified 3 years ago

#33379 closed defect (bug) (fixed)

Word count on post edit screen should be hidden if javascript is disabled

Reported by: chriscct7's profile chriscct7 Owned by: chriscct7's profile chriscct7
Milestone: 4.4 Priority: normal
Severity: normal Version:
Component: Editor Keywords: has-patch
Focuses: javascript, administration Cc:

Description

If Javascript is off, the "Word Count" should be hidden (instead of showing Word Count: 0 as it does right now regardless of how long post actually is)

Attachments (2)

33379.patch (588 bytes) - added by chriscct7 9 years ago.
33379.diff (624 bytes) - added by wonderboymusic 9 years ago.

Download all attachments as: .zip

Change History (13)

#1 follow-ups: @valendesigns
9 years ago

This just needs a .hide-if-no-js I believe.

#2 in reply to: ↑ 1 @chriscct7
9 years ago

Replying to valendesigns:

This just needs a .hide-if-no-js I believe.

Yep I think so as well. Testing that now

#3 @chriscct7
9 years ago

  • Component changed from Posts, Post Types to Editor
  • Keywords has-patch commit added; needs-patch removed
  • Milestone changed from Awaiting Review to 4.3
  • Owner set to chriscct7
  • Status changed from new to accepted

@chriscct7
9 years ago

#4 in reply to: ↑ 1 @chriscct7
9 years ago

Replying to valendesigns:

This just needs a .hide-if-no-js I believe.

Confirmed

#5 @obenland
9 years ago

  • Keywords commit removed

#6 @obenland
9 years ago

  • Version set to trunk

#7 @pento
9 years ago

The class should be on <td id="wp-word-count">, not the <table>. Same as on <td id="content-resize-handle" class="hide-if-no-js">.

#8 @ocean90
9 years ago

  • Keywords needs-patch added; has-patch removed
  • Milestone changed from 4.3 to Future Release
  • Version trunk deleted

The issue exists at least since 3.7.

@wonderboymusic
9 years ago

#9 @wonderboymusic
9 years ago

  • Keywords has-patch added; needs-patch removed
  • Milestone changed from Future Release to 4.4

#10 @wonderboymusic
9 years ago

  • Resolution set to fixed
  • Status changed from accepted to closed

In 34275:

Editor: add hide-if-no-js class to <td id="wp-word-count">. Word Count no worky with no JavaScript.

Props chriscct7.
Fixes #33379.

Note: See TracTickets for help on using tickets.