WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#33382 closed defect (bug) (fixed)

Asterisk-space sometimes doesn't convert to a bullet

Reported by: pento Owned by: azaozz
Milestone: 4.3 Priority: normal
Severity: normal Version: 4.3
Component: Editor Keywords: has-patch commit
Focuses: javascript, administration Cc:
PR Number:

Description

If you're typing quickly, sometimes you'll still be holding down the Shift key as you press Space, after pressing *.

This causes the sequence to not convert to a bullet. (The same behaviour occurs for 1) , but not for 1. , because of the lack of Shift in the latter.)

Chrome 44.0.2403.155, OSX.

Attachments (1)

33382.patch (771 bytes) - added by azaozz 4 years ago.

Download all attachments as: .zip

Change History (8)

@azaozz
4 years ago

#2 @azaozz
4 years ago

In 33382.patch: exclude shift when checking for modifier keys when applying the list patterns on pressing the spacebar.

The patterns that activate on enter are still canceled when any modifier is pressed. Currently shift + enter produces a <br> and cancels the replacement.

#3 @azaozz
4 years ago

  • Keywords has-patch needs-testing added; needs-patch removed

#4 @pento
4 years ago

  • Keywords needs-testing removed

Confirmed that the patch works for me.

+1 for commit.

#5 @obenland
4 years ago

  • Keywords commit added
  • Owner set to azaozz
  • Status changed from new to reviewing

This ticket was mentioned in Slack in #core by obenland. View the logs.


4 years ago

#7 @obenland
4 years ago

  • Resolution set to fixed
  • Status changed from reviewing to closed

In 33622:

Editor: Exclude shift from modifier keys when handling spacebar shortcuts.

Patterns that activate on enter are still canceled with any modifier active.

Props azaozz.
Fixes #33382.

Note: See TracTickets for help on using tickets.