WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#33410 closed task (blessed) (fixed)

Update .travis.yml for PHP7

Reported by: jorbin Owned by: jorbin
Milestone: 4.4 Priority: normal
Severity: normal Version:
Component: Build/Test Tools Keywords: needs-patch
Focuses: Cc:
PR Number:

Description

When PHP7 is released, we should:

1) remove PHP7 from allowed failures
2) re add PHP nightly to allowed failures so we continue to test upstream trunk

Change History (8)

#1 @wonderboymusic
4 years ago

  • Keywords needs-patch added

#2 @jorbin
4 years ago

  • Owner set to jorbin
  • Status changed from new to assigned

PHP has updated there timeline. Therefore this should happen in two separate changes (both of which can't happen yet).

First, after PHP7 is branched and master becomes 7.1 alpha, we should add nightlies to the matrix. This is scheduled for September 14.

The second is to move php7 out of the allowed failures bin. This should happen after PHP7 is officially released which is scheduled for November 12.

I will handle both of these.

This ticket was mentioned in Slack in #core by sergey. View the logs.


4 years ago

#4 @jorbin
4 years ago

In 34776:

Add PHP Nightlies to the test suite

PHP branched master for 7, which means that nightly builds are now technically 7.1. The difference is minimal at the moment, but it's a good idea for us to test against the nightly build in part so that regressions can be reported upstream. Nightlies are allowed failure so that the build doesn't go red due to unstable versions. Additionally, nightlies are not officially supported by WordPress Core.

See #33410

#5 @jorbin
4 years ago

My above comment remains true. PHP7 will be removed from the allowed failures list when PHP7 is officially released. The timeline still says November 12. RC 4 was released yesterday on schedule. http://php.net/archive/2015.php#id2015-10-01-1

This ticket was mentioned in Slack in #core by jorbin. View the logs.


4 years ago

This ticket was mentioned in Slack in #core by jorbin. View the logs.


4 years ago

#8 @jorbin
4 years ago

  • Resolution set to fixed
  • Status changed from assigned to closed

In 35633:

Remove PHP 7 from allowed failures list

PHP 7 has released it's 7th (and potentially final) Release Candidate today. While it is still not recommended for use in production, it is at a point that a test failure with it is something that needs to be triaged immediately. Congratulations to the PHP internals team on the upcoming final release of PHP 7.

Fixes #33410

Note: See TracTickets for help on using tickets.