WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#33420 closed defect (bug) (duplicate)

Static Front Page in Customiser doesn't grey out Static Page options

Reported by: stuartshields Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.3
Component: Customize Keywords:
Focuses: administration Cc:

Description

To reproduce

  1. Go to the Customise from the admin area (any theme can be enabled to duplicate the result)
  2. Then go to Static Front Page
  3. If "Front page displays" has "Your latest posts" enabled the drop down items for Front Page and Posts Page are enabled.

This was tested in Firefox 41 and Chrome Chrome 44

Results
"Front Page" and "Posts Page" are enabled even when "Front page displays" has "Your latest posts" enabled.

Expected result
"Front Page" and "Posts Page" should be disabled when "Front page displays" has "Your latest posts" enabled, just like Settings > Reading > Front page displays. Also the wording should be the same "A static page (select below)" as a pose to ""A static page" which is not hyperlinked.

Attachments (2)

Screen Shot 2015-08-19 at 3.50.18 pm.png (29.8 KB) - added by stuartshields 5 years ago.
Customise - Static front page
Screen Shot 2015-08-19 at 3.50.32 pm.png (21.4 KB) - added by stuartshields 5 years ago.
Settings > Reading - Static front page

Download all attachments as: .zip

Change History (5)

@stuartshields
5 years ago

Customise - Static front page

@stuartshields
5 years ago

Settings > Reading - Static front page

This ticket was mentioned in Slack in #core by celloexpressions. View the logs.


5 years ago

#2 @netweb
5 years ago

Adding the chat note by @ celloexpressions in Slack https://wordpress.slack.com/archives/core/p1440004003001718

"#33420, #33428 and #33434 are all duplicates. Testing, looks like the code that toggles those is conflicting with their active states. Best solution is probably to do #29948, but we likely need to figure something else out for 4.3.1. Looks like changing static front page also re-calculates the top position of the section (incorrectly),”

Related: #33428 and #33434

Possible Duplicate: #29948

#3 @westonruter
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

There is a patch to fix on #33428.

Note: See TracTickets for help on using tickets.