WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#33433 closed enhancement (duplicate)

Bring Emails into the Modern Web

Reported by: atomicjack Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Mail Keywords:
Focuses: template Cc:
PR Number:

Description

Reading over a suggestion here https://wordpress.org/ideas/topic/implement-all-system-emails-in-html-improve-look-and-feel and reviewing the comments, it does seem some attention should be brought to the emails that WordPress sends out.

One of the comments touched upon the idea of having an email template, much like we have page templates.

So we need html emails to be themeable. I'm not sure what's the best way to do it, maybe to have additional email-{type}.php template in your theme's directory

I see this as a good idea - themes can then customise the emails, and, it is also very helpful to people using WordPress for business, as they can style the emails to fit their brand.

Let's discuss?

Change History (1)

#1 @ocean90
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #18493.

Note: See TracTickets for help on using tickets.