Make WordPress Core

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#33443 closed defect (bug) (invalid)

Wordpress 4.3 New Registration email presents a password value of "both"

Reported by: tomwarneke's profile Tomwarneke Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.3
Component: Users Keywords:
Focuses: Cc:

Description

Wordpress 4.3 New Registration email presents a password value of "both". This is preventing new users from registering - critical!
Example:
Username: twg
Password: both
http://www.theobjectiveinvestor.com/wp-login.php

It works fine on version 4.2.4

Change History (9)

#1 @Tomwarneke
8 years ago

  • Severity changed from normal to critical

#2 @MikeHansenMe
8 years ago

I just ran a clean install and created a new user under the following scenarios

admin user add new default password
admin user add new show pass/default
admin edit user generate new
user self registration

I never received an email with a password in it at all. Taking a quick look at your registration on the link provided, it appears you have a plugin that alters the registration.

#3 @Tomwarneke
8 years ago

Mike,
Thank so much for taking a look at the problem.

After installing the new version of WP, I did add a couple of plugins late yesterday. I backed out one -- that put login & registration in the menu bar -- thinking that might be causing the issue, but it didn't help. I wonder if deleting it didn't completely remove the changes. The other plugin prevents non-admins from seeing the toolbar, and that is still active.

I really want a solution that lets people subscribe to the site using register and login from the menu bar, but never see the toolbar and go to the profile only if they intend to. The only thing they need to do there is change email address and password, as far as I'm concerned. If you have any suggestions, I'd be happy to hear about them.

Again, thank you!
-Tom

#4 @Tomwarneke
8 years ago

Mike,
Here is a quick question, but first a little background...
Before adding the suspect plugins, I did a Duplicator back up and saved it to my local disc - but just prior to upgrading the WP software to 4.3. So I have a 4.3 site and a 4.2.x backup. I've since backed out the plugins but the problem persist. My question is:

Can I restore the 4.2.x software with the current 4.3 mysql database? I think there was a database update with 4.3.

Thank you for any Guidance...
Tom

#5 @MikeHansenMe
8 years ago

Hey @Tomwarneke, can you create a support ticket over at https://wordpress.org/support/ for the restore problem? I would be happy to jump over there and help. Let's keep this ticket about the email problem and see if anyone else can replicate it.

Thanks

Last edited 8 years ago by MikeHansenMe (previous) (diff)

#6 @bjarkeml
8 years ago

I get this too.
Had the plugin Theme My Login installed. I first deactivated it and then uninstalled it. It didn't help.

I also had Paid Memberships Pro and Hide Admin Bar from Non-Admins installed. Uninstalled them too.

Active plugins:
Auto Submenu
Contact Form 7
Custom Facebook Feed
MailPoet Newsletters
MCE Table Buttons
Really Simple CAPTCHA
Share Buttons by AddToAny
Simple Lightbox
The Events Calendar
WP-SpamShield

Deactivated plugins:
Akismet
Hello Dolly
User Role Editor

Last edited 8 years ago by bjarkeml (previous) (diff)

#7 follow-up: @bjarkeml
8 years ago

WP-SpamShield was the problem among the plugins I am using.

#8 in reply to: ↑ 7 @RedSand
8 years ago

  • Resolution set to invalid
  • Status changed from new to closed

Replying to bjarkeml:

WP-SpamShield was the problem among the plugins I am using.

Yes...I'm the plugin author and I can confirm the issue. It's in the process of being fixed. The issue is compatibility with 4.3. Fix will be out soon.

The issue is not with WordPress. On a clean install, it works fine. New user notifications changed in 4.3.

#9 @SergeyBiryukov
8 years ago

  • Component changed from General to Users
  • Milestone Awaiting Review deleted
  • Severity changed from critical to normal
Note: See TracTickets for help on using tickets.