WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#33446 closed defect (bug) (duplicate)

Wrong unicode character conversion

Reported by: LordSilver Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.2.4
Component: Formatting Keywords: needs-patch needs-unit-tests
Focuses: Cc:

Description

You have the following case: "hello <em>world</em>".

It should be converted into this HTML code: &#8220;hello <em>world</em>&#8221; Instead, it is converted into: &#8220;hello <em>world</em>&#8220;

WordPress wrongly puts &#8220; at the end instead of &#8221; if the text contained in quotation marks ends with something contained inside <em> tag.

Change History (2)

#1 @johnbillion
3 years ago

  • Component changed from Text Changes to Formatting
  • Keywords needs-patch needs-unit-tests added
  • Milestone changed from Awaiting Review to Future Release

#2 @johnbillion
3 years ago

  • Milestone Future Release deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #18549.

Note: See TracTickets for help on using tickets.