Make WordPress Core

Opened 8 years ago

Closed 8 years ago

#33514 closed defect (bug) (fixed)

Update x Upgrade database

Reported by: pavelevap's profile pavelevap Owned by: sergeybiryukov's profile SergeyBiryukov
Milestone: 4.4 Priority: normal
Severity: normal Version:
Component: Text Changes Keywords:
Focuses: multisite Cc:


We are updating database for single site, but upgrading for multisite. We can merge it and remove 2 similar strings. We can still "Upgrade Network", but database should be "updated".

See attached patch.

Attachments (2)

33514.patch (931 bytes) - added by pavelevap 8 years ago.
33514.2.patch (1.7 KB) - added by SergeyBiryukov 8 years ago.

Download all attachments as: .zip

Change History (10)

8 years ago

#1 @pento
8 years ago

  • Focuses multisite added
  • Milestone changed from Awaiting Review to 4.4
  • Version trunk deleted

I'm cool with making the text change, but I'm wondering about the strings around it.

Should "we need to individually upgrade the sites in your network" be changed to say "update", too?

"Upgrade" in "Upgrade Network" then feels out of place. The equivalent button in single site says "Update WordPress Database".

#2 @dd32
8 years ago

The verbiage we mostly use is, Update means a filesystem change, Upgrade means a database change.

Of course, it's actually WP_Upgrader which does filesystem changes :) but upgrade.php contains database-upgrade routines.

#3 @pavelevap
8 years ago

OK, so I can reverse it :-) Upgrade for database and Update for filesystem seems reasonable, so we can change 2 single site strings (we are also within upgrade.php file). I only wanted to remove 2 similar strings with different words (found during translation)...

This ticket was mentioned in Slack in #core by sergey. View the logs.

8 years ago

#5 @SergeyBiryukov
8 years ago

  • Owner set to SergeyBiryukov
  • Status changed from new to accepted

#6 @ocean90
8 years ago

  • Component changed from I18N to Text Changes

#7 @SergeyBiryukov
8 years ago

Previously in #24931:

nacin: not sure about the second one - while we try to use "update" to mean one thing and "upgrade" to mean the other, the important part is "update"
nacin: the second part ("upgrade" meaning a DB upgrade) has always kind of been a corollary, but not necessarily set in stone
nacin: in this case we're linking it specifically to the word "database"
nacin: SergeyBiryukov: talked to jenmylo. "Update" should be preferred wherever it makes sense, including here.
nacin: I don't necessarily think that runs afoul of r23619.

33514.2.patch merges the strings and keeps "database update" on both screens.

#8 @SergeyBiryukov
8 years ago

  • Resolution set to fixed
  • Status changed from accepted to closed

In 35000:

Merge two database update strings for consistency.

Props pavelevap.
Fixes #33514.

Note: See TracTickets for help on using tickets.