WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#33546 closed defect (bug) (worksforme)

After logging out WP is still linking to ssl

Reported by: Strzyga Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.3
Component: Login and Registration Keywords: reporter-feedback, https
Focuses: Cc:
PR Number:

Description

When ssl for admin panel is enabled, after logging out, the Wordpress is still linking to ssl in the proposed link "Get back to the website..." although I am not in the admin panel any more. I often use this link and I would appreciate if you fix this bug. I know I can type the address starting with http://... myself but I find it very inconvenient, especially that you have already created the dedicated link for this action (which at the moment doesn't work correctly).

Thank you in advance,
Yours sincerely,
Joanna

Change History (5)

#1 @SergeyBiryukov
4 years ago

  • Component changed from General to Login and Registration

#2 follow-up: @johnbillion
4 years ago

  • Keywords reporter-feedback added

Thanks for the report, Strzyga. Same as in #33547, can you tell me a bit about your website configuration so we can try to reproduce the problem please? With a site that uses https for the admin area and http for the front end, the link back to the site uses the correct http protocol for me.

The text "Get back to the website" isn't part of WordPress. Do you have a plugin on your site which is adding this? As per #33547, if you could test this with all your plugins deactivated and a default them in use that would be great.

#3 in reply to: ↑ 2 @SergeyBiryukov
4 years ago

Replying to johnbillion:

The text "Get back to the website" isn't part of WordPress.

I think it's the '← Back to %s' link in login_footer().

#4 @johnbillion
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

I've been playing around with various HTTPS configurations over the last few days and I'm not able to reproduce this bug.

Please re-open if you can provide any more details, especially your HTTPS configuration and any plugins you're running.

#5 @johnbillion
4 years ago

  • Keywords https added
Note: See TracTickets for help on using tickets.