WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#33569 closed defect (bug) (fixed)

missing file comment-functions.php

Reported by: mikeyhoward1977 Owned by: SergeyBiryukov
Milestone: 4.4 Priority: high
Severity: normal Version: 4.4
Component: Upgrade/Install Keywords: has-patch
Focuses: Cc:

Description

My dev site auto updated to 4.4-alpha-33765 last night and it seems the wp-includes/comments.php file has been changed. It now makes a call to include comment-functions.php but that file does not exist and causes a PHP Fatal error thus rendering me unable to access the admin.

Attachments (2)

Screenshot_2015-08-27-13-29-55.png (98.7 KB) - added by ddmboss 6 years ago.
Screenshot of what I see when I try to enter the admin
33569.patch (500 bytes) - added by rachelbaker 6 years ago.
Removes wp-includes/comment-functions.php from the $_old_files array

Download all attachments as: .zip

Change History (17)

#1 @SergeyBiryukov
6 years ago

Hi @mikeyhoward1977, welcome to Trac!

I could not reproduce the issue, wp-includes/comment-functions.php does exist in the repository and in the latest nightly build.

#2 @dd32
6 years ago

I've also verified that wp-includes/comment-functions.php exists within the nightly build packages.

Unfortunately this sounds like it might've been a failed/incomplete update somehow.

This ticket was mentioned in Slack in #core by swissspidy. View the logs.


6 years ago

#4 @afragen
6 years ago

I see this also, updating using the Beta Tester plugin.

#5 @jadpm
6 years ago

Experiencing this too, using the Beta Tester plugin. It happened to me twice today, so not likely an upgrade process issue, and it is quite odd since the file itself is on the wordpress-latest.zip

#6 @ddmboss
6 years ago

I also have this exact issue on my website.

@ddmboss
6 years ago

Screenshot of what I see when I try to enter the admin

#7 @jonathansulo
6 years ago

Same issue here, using the Beta Tester plugin. Tried to fetch the latest-build several times just now but keep getting the same error. I managed to resolve it by manually copying comment-functions.php into wp-includes/.

#8 @ocean90
6 years ago

  • Component changed from Bootstrap/Load to Upgrade/Install
  • Keywords needs-patch added
  • Milestone changed from Awaiting Review to 4.4
  • Priority changed from normal to high

'wp-includes/comment-functions.php' needs to be removed from $_old_files (trunk/src/wp-admin/includes/update-core.php).

@rachelbaker
6 years ago

Removes wp-includes/comment-functions.php from the $_old_files array

#9 @rachelbaker
6 years ago

  • Keywords has-patch added; needs-patch removed

#10 @SergeyBiryukov
6 years ago

  • Owner set to SergeyBiryukov
  • Resolution set to fixed
  • Status changed from new to closed

In 33772:

Remove wp-includes/comment-functions.php from the $_old_files array. See [33750].

props rachelbaker.
fixes #33569.

#11 follow-up: @swissspidy
6 years ago

Would a unit test make sense here? Testing that none of the files in the array exist in the repo.

#12 in reply to: ↑ 11 ; follow-up: @SergeyBiryukov
6 years ago

Replying to swissspidy:

Would a unit test make sense here? Testing that none of the files in the array exist in the repo.

Probably, if it won't add a noticeable slowdown when running the suite. Let's create a new ticket for that.

This ticket was mentioned in Slack in #core by sergey. View the logs.


6 years ago

This ticket was mentioned in Slack in #core by ocean90. View the logs.


6 years ago

#15 in reply to: ↑ 12 @SergeyBiryukov
6 years ago

Follow-up: #36083

Note: See TracTickets for help on using tickets.