WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#33572 closed defect (bug) (duplicate)

Fix the "E-mail me whenever" text (and maybe behavior) in the Discussion Settings screen

Reported by: samuelsidler Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Comments Keywords: needs-patch ux-feedback
Focuses: Cc:

Description

The Discussion Settings screen includes this bit of text:

E-mail me whenever

However, the setting associated with that text are global settings, not personal ones. The intention here was likely that only the administrator of the site can change that setting and, since their email is the one associated with site, they're the one that would receive the email. There are two problems with this:

  1. There could be more than one administrator on the site and that administrator would not receive the emails.
  2. The settings associated with this text aren't actually ones that go to just the administrator. (At least one isn't...) "E-mail me whenever... Anyone posts a comment" applies to post authors as well.

(Note: I have no idea if "E-mail me whenever... A comment is held for moderation" applies to post authors and administrators, but I know it applies to administrators. Someone should confirm either way.)

This text is really confusing. If we want to have a personal setting for emails, we should add that somewhere else. But if one of these settings is for post authors and one is for administrators, that's even more confusing.

So, how should this read? What should this setting do?

Change History (1)

#1 @SergeyBiryukov
5 years ago

  • Milestone 4.4 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #6286.

Note: See TracTickets for help on using tickets.