WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#33613 closed defect (bug) (invalid)

Warning in core

Reported by: ssteiner Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Plugins Keywords:
Focuses: Cc:

Description

( ! ) Warning: Creating default object from empty value in /Users/ssteiner/Desktop/studleys/wp-admin/includes/plugin-install.php on line 95
Call Stack
# Time Memory Function Location
1 0.0020 424280 {main}( ) ../update-core.php:0
2 2.2114 83216656 list_plugin_updates( ) ../update-core.php:565
3 2.2140 83384512 plugins_api( ) ../update-core.php:256

Change History (2)

#1 @SergeyBiryukov
5 years ago

  • Component changed from Administration to Plugins
  • Focuses administration added

This looks like something caused by a plugin hooking into the 'plugins_api' filter.

Per the filter documentation, the result should be either boolean or object, and both cases are appropriately handled in lines 68—96.

#2 @chriscct7
5 years ago

  • Focuses administration removed
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed
  • Version 4.3 deleted

Based on the stacktrace, there is a plugin that's intercepting the update information in the update plugins list and sending back a non-standard value that's not supported by the plugins_api filter.

Note: See TracTickets for help on using tickets.