WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#33617 closed defect (bug) (fixed)

Visual Editor freezing when I add multiple HTML tables to the post

Reported by: dankop Owned by: azaozz
Milestone: 4.3.1 Priority: normal
Severity: normal Version: 4.3
Component: TinyMCE Keywords:
Focuses: Cc:
PR Number:

Description

Ever since I updated my website to 4.3 my visual editor is freezing every time I try to highlight a piece of text, or even place my cursor someplace random. This only seems to be happening on the text contained within a HTML table, especially when you have multiple tables below each other. When I open console tab in Chrome, following error is displayed over and over again:

Uncaught RangeError: Maximum call stack size exceeded -- tinymce.min.js?ver=4203-20150730:7

I tried disabling all of my addons and changing my theme. Also installed a fresh copy of WordPress on a sub-domain, and on a local XAMPP server. Happened every time, and seems to only be related to 4.3. - since everything works fine on a 4.2.3 website that I still haven't updated.

To replicate this error, copy the HTML table code bellow and paste it couple of times in a new post - around ten or so, enough so that you can actually scroll the page a good amount. Then try scrolling the page in the Visual Editor with your mouse-wheel and while doing so try to select a piece of text. This without exception freezes my screen for good 4-5 seconds. Might not happen right away, but just keep scrolling up and down, and click your cursor on random places withing those tables.

<h3>Title</h3>
<table>
<tbody>
<tr><td><p>Nulla ac vehicula nunc. Sed sed maximus lectus, a cursus ligula. Aliquam enim lacus, mollis quis vestibulum et, imperdiet et enim. Cum sociis natoque penatibus et magnis dis parturient montes, nascetur ridiculus mus. Curabitur eget gravida est, a vehicula tortor. Curabitur aliquam lorem justo, vitae maximus metus porttitor vel. Aliquam neque mauris, posuere a mauris sit amet, ullamcorper accumsan velit.</p><p>Aenean vitae condimentum lacus. Vivamus sit amet velit quis lectus dapibus laoreet. Fusce ultricies aliquet arcu ac lacinia. Vivamus a erat ut erat ornare bibendum vel vitae velit. Vestibulum ut tellus quis magna luctus scelerisque pulvinar sit amet orci. Pellentesque habitant morbi tristique senectus et netus et malesuada fames ac turpis egestas. In malesuada ligula in ante pharetra, id euismod est tempor.</p></td></tr>
</tbody>
</table>

Change History (8)

#1 follow-up: @azaozz
4 years ago

Hi @dankop, thanks for the bug report.

Confirmed in both Firefox and Chrome. Not caused by our custom plugins, happens in the TinyMCE demo: http://www.tinymce.com/tryit/basic.php (use Tools => Source code to paste the test html). Passing upstream for further investigation.

#2 in reply to: ↑ 1 @dankop
4 years ago

Replying to azaozz:

Alright, thanks for the swift feedback!

#3 follow-up: @azaozz
4 years ago

This actually was fixed upstream couple of days ago: https://github.com/tinymce/tinymce/commit/431bf04da54599239cb1577dcff75032c6897855. Will be in the next TinyMCE update.

Last edited 4 years ago by azaozz (previous) (diff)

#4 in reply to: ↑ 3 @dankop
4 years ago

Replying to azaozz:
That's very good to know, thanks! Hoping for a quick patch then.

#5 @azaozz
4 years ago

  • Milestone changed from Awaiting Review to 4.3.1

Consider for fixing in 4.3.1. Needs TinyMCE to be updated to at least 4.2.5.

#6 @samuelsidler
4 years ago

  • Owner set to azaozz
  • Status changed from new to assigned

#7 @azaozz
4 years ago

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed in r34029.

#8 @azaozz
4 years ago

#33851 was marked as a duplicate.

Note: See TracTickets for help on using tickets.