WordPress.org

Make WordPress Core

#33647 closed defect (bug) (fixed)

On Add new user page, password text field does not get focussed on clicking 'New password' label

Reported by: juhise Owned by:
Milestone: 4.4 Priority: normal
Severity: normal Version: 4.3
Component: Users Keywords: has-patch
Focuses: ui, accessibility, administration Cc:

Description

On Add new user page, Password has label and cursor pointer both. And there should not be cursor and label on password text.
There is no any effect after clicking on "Password" text. It is creating confusion to user after click.

Attachments (4)

33647.patch (582 bytes) - added by juhise 22 months ago.
patch file after removed label
Add_New_User_‹_Site_4.3_test_Google_yahoo_—_WordPress_-_2015-09-01_20.50.22.png (7.8 KB) - added by juhise 22 months ago.
screen shots of new user page
33647.1.patch (639 bytes) - added by Ankit K Gupta 22 months ago.
patch for user-edit.php page
33647.2.patch (1.3 KB) - added by juhise 22 months ago.
Associated the label with "pass1-text" field

Download all attachments as: .zip

Change History (21)

@juhise
22 months ago

patch file after removed label

#1 @SergeyBiryukov
22 months ago

  • Component changed from General to Users
  • Milestone changed from Awaiting Review to 4.4
  • Version changed from trunk to 4.3

#2 @Ankit K Gupta
22 months ago

This ticket look sounds good for user accessibility.
On user-edit.php page, New Password Page should not have label.
Added patch file for the same.

Last edited 22 months ago by Ankit K Gupta (previous) (diff)

@Ankit K Gupta
22 months ago

patch for user-edit.php page

#3 @Ankit K Gupta
22 months ago

  • Keywords has-patch added

#4 @afercia
22 months ago

By the way, when the field is displayed and then you click on the "hide" button to hide the password, the label will be correctly associated with the "pass1" field. When hidden instead, maybe the label should be associated with the "pass1-text" field. This probably got a bit messed up after the fix for IE 8 that split the field in two different fields (one with type "password" and one with type "text").

#5 @HeadOnFire
22 months ago

Addind id attribute to "Show password" button and changing <label for="that_id"> makes clicking a label act like the button itself - show the password. Imo, that's expected behaviour. It works fine when password is shown, however, when password is hidden it does not put the focus into the field. And that's strange.

#6 @SergeyBiryukov
22 months ago

  • Focuses accessibility added

@juhise
22 months ago

Associated the label with "pass1-text" field

#7 @juhise
22 months ago

Totally agree with afercia ,referring https://core.trac.wordpress.org/ticket/33647#comment:4.
Label should be associated with "pass1-text" field also. Created the patch accordingly.

#8 follow-up: @umesh.nevase
22 months ago

I've reported same issue https://core.trac.wordpress.org/ticket/33778, but this issue is exists on all 'Generate password' button in 'profile.php', 'user-new.php' and also when we installing new wordpress 'install.php'. I've added patch for all pages in this ticket.

This ticket was mentioned in Slack in #core by juhisaxena. View the logs.


22 months ago

#10 @juhise
22 months ago

  • Summary changed from On Add new user page, Password has label and cursor pointer. to On Add new user page, password text field does not get focussed on clicking 'New password' label

#11 @chiragswadia
22 months ago

#33850 was marked as a duplicate.

#12 in reply to: ↑ 8 @chiragswadia
22 months ago

Replying to umesh.nevase:

I've reported same issue https://core.trac.wordpress.org/ticket/33778, but this issue is exists on all 'Generate password' button in 'profile.php', 'user-new.php' and also when we installing new wordpress 'install.php'. I've added patch for all pages in this ticket.

Not sure why you have created a new ticket ( https://core.trac.wordpress.org/ticket/33850 ) for the same issue even when it is addressed here. I have marked the other ticket as duplicate.

Last edited 22 months ago by chiragswadia (previous) (diff)

#13 follow-up: @chiragswadia
22 months ago

#33850 was marked as a duplicate.

#14 in reply to: ↑ 13 ; follow-ups: @umesh.nevase
22 months ago

Replying to chiragswadia:

#33850 was marked as a duplicate.

In https://core.trac.wordpress.org/ticket/33778 I haven't got any reply for update profile page, so I created a new ticket https://core.trac.wordpress.org/ticket/33850.

Last edited 22 months ago by umesh.nevase (previous) (diff)

#15 in reply to: ↑ 14 @chiragswadia
22 months ago

Replying to umesh.nevase:

Replying to chiragswadia:

#33850 was marked as a duplicate.

In https://core.trac.wordpress.org/ticket/33778 I haven't got any reply for update profile page, so I created a new ticket https://core.trac.wordpress.org/ticket/33850.

Since this is not a high priority blocking issue, it might take some time for any developer to give feedback. Opening a new ticket will not do any good. It will be better if you followup on the original ticket instead https://core.trac.wordpress.org/ticket/33778

#16 in reply to: ↑ 14 @netweb
22 months ago

Replying to chiragswadia:

Replying to umesh.nevase:

Replying to chiragswadia:

#33850 was marked as a duplicate.

In https://core.trac.wordpress.org/ticket/33778 I haven't got any reply for update profile page, so I created a new ticket https://core.trac.wordpress.org/ticket/33850.

Since this is not a high priority blocking issue, it might take some time for any developer to give feedback. Opening a new ticket will not do any good. It will be better if you followup on the original ticket instead https://core.trac.wordpress.org/ticket/33778

@umesh.nevase and @chiragswadia #33778 was part of the 4.3.1 milestone that shipped ~22 hours ago, please do not reopen this ticket, if needed please reopen #33850 if it is not a duplicate of this ticket.

#17 @wonderboymusic
21 months ago

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.