WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#33691 closed defect (bug) (duplicate)

Mixed content being served over ssl

Reported by: cleggmatt Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.4
Component: General Keywords:
Focuses: Cc:

Description

Images are stored with the full path even though they are on the same domain. This causes mixed-content problems if you migrate to HTTPS from HTTP.

Attachments (1)

force-url_scheme-content-for-own-domain.patch (851 bytes) - added by cleggmatt 6 years ago.

Download all attachments as: .zip

Change History (4)

#1 @akumria
6 years ago

I like the idea behind this patch, but I would approach this differently.

If instead of storing the full site_domain for an image in a post, WP just stored protocol relative URLs (i.e. the image path but prefixed with '' and no http or https) then switching a site from http to https (or vice versa for some reason) would be simpler.

Your patch would be a great migration helper so that people who upgraded to a newer version of WP could benefit from such a core change.

Version 0, edited 6 years ago by akumria (next)

This ticket was mentioned in Slack in #core by johnbillion. View the logs.


6 years ago

#3 @johnbillion
6 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Dupe of #29727. See also #28521.

Note: See TracTickets for help on using tickets.