WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#33695 closed defect (bug) (fixed)

Customize: shift-clicking a widget in the preview doesn't move focus

Reported by: afercia Owned by: westonruter
Milestone: 4.3.1 Priority: normal
Severity: normal Version: 4.3
Component: Customize Keywords: has-patch commit fixed-major
Focuses: ui, accessibility, javascript Cc:
PR Number:

Description

See related #33258 and #33220.
Looks like after 33610 when shift clicking a widget in the preview iframe the widget correctly opens in the sidebar but focus doesn't get moved to the first focusable element in the sidebar expanded panel.

As far as I remember, it correctly worked after 33596. Broken now probably because it returns a wrong "focusContainer" since the first ul there is the (hidden) one inside .move-widget-area.

Attachments (1)

33695.diff (826 bytes) - added by westonruter 4 years ago.

Download all attachments as: .zip

Change History (9)

This ticket was mentioned in Slack in #core-customize by afercia. View the logs.


4 years ago

@westonruter
4 years ago

#2 follow-up: @westonruter
4 years ago

  • Keywords has-patch added
  • Owner set to westonruter
  • Status changed from new to accepted

@afercia: Nice catch. See 33695.diff which has the fix. The problem is that widgets also have an expanded property, so they incorrectly get interpreted as a panel/section. So we just have to be more explicit about the different construct types when determining the focus container.

Should this not be milestoned for 4.3.1?

#3 in reply to: ↑ 2 @afercia
4 years ago

@westonruter thanks :)

Should this not be milestoned for 4.3.1?

Actually, I wasn't sure what to do when setting the milestone :)

#4 @westonruter
4 years ago

  • Milestone changed from 4.4 to 4.3.1

Milestoning it.

@afercia: Can you confirm it works? If so, add commit keyword. Thx!

#5 @afercia
4 years ago

  • Keywords commit added

It works :)

#6 @westonruter
4 years ago

  • Resolution set to fixed
  • Status changed from accepted to closed

In 33939:

Customize: Fix logic for determining the container element when focusing on a panel, section, or control.

Fixes #33695 for trunk.

#7 @westonruter
4 years ago

In 33940:

Customize: Fix logic for determining the container element when focusing on a panel, section, or control.

Cherry-picks [33939] on the 4.3 branch.
Fixes #33695 for 4.3

#8 @westonruter
4 years ago

  • Keywords fixed-major added
Note: See TracTickets for help on using tickets.