WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#33698 closed defect (bug) (duplicate)

SERVER_NAME may not be set in wp_mail()

Reported by: szepe.viktor Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.4
Component: Mail Keywords:
Focuses: Cc:

Description

$sitename = strtolower( $_SERVER['SERVER_NAME'] ); results in an empty string thus an invalid sender address: wordpress@

Please fall back to $_SERVER['HTTP_HOST'].

Change History (1)

#1 @SergeyBiryukov
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #25239.

Note: See TracTickets for help on using tickets.