Make WordPress Core

Opened 20 years ago

Closed 20 years ago

Last modified 20 years ago

#337 closed defect (bug) (fixed)

Wordpress is not compatible with PHP 4.1.*

Reported by: cal's profile cal Owned by: michel-v's profile michel v
Milestone: Priority: normal
Severity: critical Version:
Component: General Keywords:
Focuses: Cc:


Various bits of wordpress are using php 4.2 and 4.3 only features.

wp-include/class-IXR.php needs is_a(), which appeared in PHP 4.2.0

xmlrpc.php needs ob_clean(), which appeared in PHP 4.2.0

functions-post.php needs print_r() with 2 arguments, which appeared in PHP 4.3.0

There are lots of other functions which have changed since PHP 4.1.0, so it makes sense to dela with these all in one place. The attached patch contains /wp-includes/functions-compat.php, to hold all php version compatability functions, and is include_once()'d in the needed places.

with this patch applied, i can post fine via the metaweblog api.

Attachments (1)

0000337-wp_compat.diff (4.5 KB) - added by cal 19 years ago.

Download all attachments as: .zip

Change History (5)

#2 @michel v
20 years ago

  • Owner changed from anonymous to michel v
  • Status changed from new to assigned

#3 @michel v
20 years ago

  • Resolution changed from 10 to 20
  • Status changed from assigned to closed

Added functions-compat to CVS, with proper attributions. Thanks for the heads up!

Note: See TracTickets for help on using tickets.