WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 8 years ago

#3370 closed defect (bug) (worksforme)

Do not have permission to add category.

Reported by: computerwolf Owned by: mdawaffe
Milestone: Priority: normal
Severity: normal Version: 2.0.5
Component: Administration Keywords: category permission adding
Focuses: Cc:

Description

Ever since upgrading from 2.0.4 to 2.0.5, whenever I attempt to add a category, I get the message, "You don't have permission to do that." when on the page to add a new post. I am the administrator and can add categories fine from the category area in the admin. I have already attempted a fresh install of 2.0.5, and still receive the error.

Attachments (1)

3370-plugin.php (557 bytes) - added by mdawaffe 8 years ago.

Download all attachments as: .zip

Change History (15)

comment:1 @foolswisdom8 years ago

Hi computerwolf,

Still at a loss as to what is causing this. As this has not been reported more generally, it is likely something specific to your environment. Any other clues? How are you connected to the Internet? Is it over proxy?

comment:2 @computerwolf8 years ago

I am connected to the internet on a LAN by cable modem, and have had the problem on multiple computers. The problem only appeared after the upgrade so I figured it was code related. I have no javascript errors on any other pages that I know of.

comment:3 @computerwolf8 years ago

  • Milestone set to 2.0.5

comment:4 @anonymous8 years ago

  • Milestone 2.0.5 deleted

Milestone 2.0.5 deleted

comment:5 @foolswisdom8 years ago

This will probably require direct debugging on your server. I would volunteer, but I do not yet have the expertise.

comment:6 @computerwolf8 years ago

Why would that aspect of 2.0.4 work on my server and not 2.0.5? The server meets all the requirements. What has changed between the two that would cause this unwanted error?

comment:7 @computerwolf8 years ago

  • Milestone set to 2.0.6

ok, I opened up wp-admin/edit-form-ajax-cat.php and removed

if ( !check_ajax_referer() )
	die('-1');

I could then add categories just fine. I then went to delete the new test categories I had made and found that I got the same permission error there as well.

So what change between the versions would cause check_ajax_referer() to fail?

comment:8 @ryan8 years ago

[4053] could be responsible.

comment:9 @mdawaffe8 years ago

  • Owner changed from anonymous to mdawaffe
  • Status changed from new to assigned

computerwolf,

I'm trying to reproduce the problem but am having a hard time.

Can you email me privately? mda AT blogwaffe TOD com

comment:10 @markjaquith8 years ago

mdawaffe,

Have you made any progress on this?

[4053] went in before 2.0.4, so he would have been having this problem back then if that was the sole culprit.

Have we verified that the 2.0.5 files are intact and that there wasn't a "partial upgrade" ?

This person in the forums seems to have the same problem with deleting posts via AJAX:

http://wordpress.org/support/topic/94791

(or maybe computerwolf == pemondoux)

Not sure whether this is PEBKAC or just a very rare and very specific server setup.

comment:11 @mdawaffe8 years ago

I do not believe this is PEBKAC.

I have made no progress. Originally, I thought this was due to a bad encoding of a username or passward hash, but that seems not to be the case.

computerwolf, If you disable all plugins, do you still see the issue?

Could you try installing the plugin 3370-plugin.php (found in the attachment section of this page) to see if that helps?

@mdawaffe8 years ago

comment:12 @computerwolf8 years ago

I used a brand new installation of 2.0.5 and activated your plugin and still receive the error.

comment:13 @foolswisdom8 years ago

computerwolf, http://wordpress.org/support/topic/96531?replies=14#post-482545 sounds like a similar scenario. Does that help your issue?

comment:14 @foolswisdom8 years ago

  • Milestone 2.0.6 deleted
  • Resolution set to worksforme
  • Status changed from assigned to closed

Removing milestone and marking works for me, until new info.

Note: See TracTickets for help on using tickets.