WordPress.org

Make WordPress Core

Opened 4 years ago

Last modified 4 months ago

#33773 new enhancement

Media, Featured Images: The media modal doesn't remember filter settings in the context of featured images

Reported by: ryan Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.3
Component: Media Keywords: make-flow
Focuses: ui Cc:
PR Number:

Description (last modified by ryan)

https://make.wordpress.org/flow/2015/09/07/media-featured-images-setting-the-featured-image-on-an-old-post-macnchrome/

A thread on #23205 discusses featured image flow through the media modal. There are requests that the filter in the media modal remember the “uploaded to this post” filter setting independently for the featured image flow.

Considerations:

  • “Uploaded to this post” requires that the image be attached to a post. Images uploaded through the media modal from the editor are attached to the post, but images uploaded directly to the media library are not attached and don’t get attached later when added to a post. We could use some API for pulling images out of post content, like we do with some other media types. See related discussions on #23041 "Images Don't Become Attached When Inserting a Gallery" and #32622 "Make the text of the Image delete AYS dialog clearer".
  • If no images are attached to the post, the filter should be set to show all images.

Change History (3)

#1 @ryan
4 years ago

  • Summary changed from Media, Featured Images: The media modal doesn't remember filter settings in the context featured images to Media, Featured Images: The media modal doesn't remember filter settings in the context of featured images

#2 @ryan
4 years ago

  • Description modified (diff)

This ticket was mentioned in Slack in #core-flow by boren. View the logs.


4 years ago

Note: See TracTickets for help on using tickets.