WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 2 years ago

#33807 closed defect (bug) (duplicate)

overload proceesor

Reported by: ramymelegy Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.3
Component: Cron API Keywords:
Focuses: Cc:

Description (last modified by ocean90)

i have a wordpress on ubuntu server all last update
after i upgrade to last version wordpress sudenly the processor full (8 cores)
i upgrade my server to 16 core and still overloading
after that i do the below
Step 1. Fix the actual issue by applying part of the patch in that ticket. It's a one liner. Open the wp-includes/taxonomy.php file, and go to line 4448. This is that line:

wp_schedule_single_event( 'wp_batch_split_terms', time() + MINUTE_IN_SECONDS );

The problem is that the arguments are reversed. Switch them, like so:

wp_schedule_single_event( time() + MINUTE_IN_SECONDS, 'wp_batch_split_terms' );

That will fix the underlying issue, but it won't stop the load. To do that, we're going to make a temporary mu-plugin.

Step 2. Navigate to your /wp-content directory. Create a subdirectory called "mu-plugins", at /wp-content/mu-plugins. The name of the directory is important. If you already have that directory, just go in there.

Create a new file called "fix.php".

<?php
function clear_bad_cron_entries() {
	// Fix incorrect cron entries for term splitting
	$cron_array = _get_cron_array();
	if ( isset( $cron_array['wp_batch_split_terms'] ) ) {
		unset( $cron_array['wp_batch_split_terms'] );
	        _set_cron_array( $cron_array );
	}
}
clear_bad_cron_entries();

i want to inform you thats fix my problem and hope to upgrade soon to solve this problem
regards

Change History (1)

#1 @ocean90
2 years ago

  • Description modified (diff)
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Hi ramymelegy, welcome to trac.

Thanks for your report. We're tracking this issue in #33423, it will be fixed with the next minor release.

Note: See TracTickets for help on using tickets.