WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#33811 closed defect (bug) (fixed)

"Attribute content to" dropdown missing when deleting a user in network admin (multisite)

Reported by: figureone Owned by: jeremyfelt
Milestone: 4.3.1 Priority: normal
Severity: normal Version: 4.3
Component: Networks and Sites Keywords: has-patch fixed-major
Focuses: multisite Cc:

Description (last modified by SergeyBiryukov)

Changeset [32333] introduced a bug that removed the html select element from the rendered output. The cause is an early closing parenthesis to the _e() function.
https://core.trac.wordpress.org/changeset/32333/trunk/src/wp-admin/network/users.php

Simple fix in attached patch. Screenshots attached to illustrate.
/wp-admin/network/users.php

Attachments (3)

fix-missing-user-dropdown.patch (824 bytes) - added by figureone 4 years ago.
Screen Shot 2015-09-10 at 9.46.47 AM.png (47.6 KB) - added by figureone 4 years ago.
Screenshot illustrating missing html select element.
33811.diff (839 bytes) - added by jeremyfelt 4 years ago.

Download all attachments as: .zip

Change History (16)

@figureone
4 years ago

Screenshot illustrating missing html select element.

#1 @figureone
4 years ago

  • Keywords has-patch added

#2 @jeremyfelt
4 years ago

  • Milestone changed from Awaiting Review to 4.4
  • Owner set to jeremyfelt
  • Status changed from new to accepted
  • Version changed from trunk to 4.3

Hi @figureone, thanks for the report and the patch!

I'll alter it slightly as the "Attribute all content to:" does need to be contained in _e() for translation.

#3 @figureone
4 years ago

Awesome, thanks @jeremyfelt.

@jeremyfelt
4 years ago

#4 @jeremyfelt
4 years ago

  • Milestone changed from 4.4 to 4.3.1

33811.diff closes the translation and outputs the user dropdown on a new line.

I'm going to assign this to 4.3.1 as it breaks a process pretty badly.

#5 @jeremyfelt
4 years ago

  • Resolution set to fixed
  • Status changed from accepted to closed

In 34012:

Multisite: Display content attribution drop down when deleting a user

The previous move from echo() to _e() left some of the output hanging. Introduced in [32333].

Props figureone.
Fixes #33811 for trunk.

#6 @jeremyfelt
4 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

Reopening for 4.3.1 consideration

#7 @jeremyfelt
4 years ago

  • Keywords fixed-major added

#8 @jeremyfelt
4 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

In 34058:

Multisite: Display content attribution drop down when deleting a user

The previous move from echo() to _e() left some of the output hanging. Introduced in [32333].

Merge of [34057] to the 4.3 branch.

Props figureone.
Fixes #33811.

#9 @jeremyfelt
4 years ago

Yeah. Merge of [34012] to the 4.3 branch... :)

#10 @figureone
4 years ago

Sweet. Thanks for the fast turnaround!

#11 follow-up: @tanguysauvin
4 years ago

Hi,

This patch creates a bug, the former version was correct:

<?php echo __( 'Attribute all content to:' ) . "</label>\n" . $user_dropdown; ?></li> 

The new version doesn't make sense since _e is a wrapper for echo and enclose only 'Attribute all content to:' and not the end of the statement:

<?php _e( 'Attribute all content to:' ) . "</label>\n" . $user_dropdown; ?></li> 

A really correct version would be (cause commas are a bit faster):

<?php echo __( 'Attribute all content to:' ), "</label>\n", $user_dropdown; ?></li> 

#12 @SergeyBiryukov
4 years ago

  • Description modified (diff)

#13 in reply to: ↑ 11 @SergeyBiryukov
4 years ago

Replying to tanguysauvin:

The new version doesn't make sense since _e is a wrapper for echo and enclose only 'Attribute all content to:' and not the end of the statement:

<?php _e( 'Attribute all content to:' ) . "</label>\n" . $user_dropdown; ?></li> 

This was fixed in [34012].

Note: See TracTickets for help on using tickets.