WordPress.org

Make WordPress Core

Opened 4 years ago

Last modified 4 months ago

#33896 new defect (bug)

Gallery linking to Attachment page

Reported by: pavelevap Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Media Keywords:
Focuses: Cc:
PR Number:

Description

I have received some user reports recently, that they are using internal WordPress gallery (which was improved) and there is some strange problem.

  • Create new post
  • Create new gallery with existing images from Media library (do not upload new images).
  • Link gallery to Attachment page.
  • See post on website, click on first image in gallery.
  • You will see links to next/previous image, but not related to user created gallery. Instead of created gallery you can see all images attached (uploaded) to some other post.

Users do not understand that this is how it works (gallery shortcode x attachments uploaded to post), they are only asking what is wrong. Maybe we should disable possibility to link to Attachment page when all images from gallery are not uploaded to current post?

Change History (4)

#1 @SergeyBiryukov
4 years ago

  • Component changed from General to Media

#3 @pavelevap
4 years ago

Thank you Sergey, I tried to search, but did not find this ticket. So, there is a filter which could be used to repair this behaviour? But I did not find any simple plugin to do it...

It does not look good when there is available option for users which will lead them to broken functionality...

#4 @obenland
4 years ago

  • Version trunk deleted
Note: See TracTickets for help on using tickets.