WordPress.org

Make WordPress Core

Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#3390 closed enhancement (duplicate)

Better get_page_uri

Reported by: ryanscheuermann Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.0.5
Component: Administration Keywords:
Focuses: Cc:

Description

I posted this ticket for trunk, but I figured I'd duplicate it here as well.

This patch replaces get_page_uri with a version that only executes 1 general query instead of 1 for every single page in the tree. This is mainly an optimization for pages that display complete page heirarchies / navigation menus.

The trunk ticket is here: #3373

Attachments (1)

get_page_uri.2.0.5 (1.4 KB) - added by ryanscheuermann 9 years ago.
better & faster get_page_uri

Download all attachments as: .zip

Change History (3)

@ryanscheuermann9 years ago

better & faster get_page_uri

comment:1 @foolswisdom9 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Marking as duplicate of 3373. Only one ticket for a problem regardless of the version or milestone.

Thank you for contributing to WordPress!

I am a layperson, but the nature of the problem and the fix looks great!

comment:2 @markjaquith8 years ago

  • Milestone 2.0.6 deleted
Note: See TracTickets for help on using tickets.