WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#33935 closed defect (bug) (invalid)

Canceling post date edit has un-anticipated result

Reported by: ifyouwillit Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.4
Component: Date/Time Keywords:
Focuses: ui, javascript, administration Cc:
PR Number:

Description

When editing a post date on a new post and then clicking the cancel button, the date is reverted back to 'publish immediately'. However, if publish date is changed once, and then subsequently re-edited before a page update, the date is still reverted to 'publish immediately' on cancel link click, rather than to the previous state of the publish date box.

To reproduce:
1) Click edit link under publish date
2) Change to future date and click ok
3) Click edit link again under publish date
4) Click cancel (date is reverted to publish immediately, but should be un-changed from previous update)

Change History (3)

#1 @juhise
4 years ago

Hello ifyouwillit,

This is your first bug report to WP core. Welcome to core track.

According to description, it does not seem to be a bug, It's expected behavior. It's not the case with publish date, it's with all options, status, visibility, because you are just selecting the date not saving it. The state will not be saved until you click on the Schedule button

Last edited 4 years ago by juhise (previous) (diff)

#2 @johnbillion
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

As @juhise excellently explained, this is expected behaviour. At this point the post does not have a date, and 'Cancel' reverts the date to the post's date, not the previously chosen date.

#3 @ifyouwillit
4 years ago

Got it. Thanks for the explanation.

Note: See TracTickets for help on using tickets.