WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#33992 closed defect (bug) (duplicate)

User Edit page , Submit button DISABLED on Chrome with Google account logged-in

Reported by: mfonsatti Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.3.1
Component: Users Keywords:
Focuses: Cc:
PR Number:

Description

[WP_4.3.1] Only on User edit page , and only with chrome , if i'm logged in with my google account , every click on user edit page , add a DISABLE attribute on update user submit button . Tested with different PC[windows/linux] .

Change History (8)

#1 @ocean90
4 years ago

  • Keywords reporter-feedback added

Hello @mfonsatti, welcome to Trac.

Seems like you are using a plugin to be able to login with your Google Account, which one? Does it still happen with all plugins disabled and a default theme activated?

#2 @caplain
4 years ago

I'm experiencing the same problem simply using any site user account including my admin account.

I'm finding that if I go to a user profile page /wp-admin/user-edit.php?user_id=[id] the 'Update User' button is active, however if I make ANY change to the profile, e.g. simply unchecking 'Show Toolbar when viewing site' the 'Update User' button immediately goes inactive. Other than Themeco X theme plugins my site is pretty vanilla. I've disabled the other few plugins that I added.

#3 @caplain
4 years ago

Update: I discovered clicking anywhere on the user edit page causes the 'Update User' button to be changed to disabled.

<form id="your-profile" action="http://df9.51b.myftpupload.com/wp-admin/user-edit.php" method="post" novalidate="novalidate">
...
<input type="submit" name="submit" id="submit" class="button button-primary" value="Update User" disabled="">
</form>

#4 follow-up: @knutsp
4 years ago

Does the "Confirm use of weak password" checkbox also show up? When it does, and unchecked, the submit button gets disabled.

#5 in reply to: ↑ 4 ; follow-up: @mfonsatti
4 years ago

Replying to knutsp:

Does the "Confirm use of weak password" checkbox also show up? When it does, and unchecked, the submit button gets disabled.

the "Confirm use of weak password" is not checked ... When i check it , the submit button turn to active ... ... that's a problem because i would modify an user without mod the password ...

#6 in reply to: ↑ 5 @SergeyBiryukov
4 years ago

Related: #33441, #33699.

#7 @knutsp
4 years ago

  • Keywords close added; reporter-feedback removed

I, and clients, have this problem, and I believe it's quite common. No password keeper involved, and it happens in more than one browser type. Sometimes, just hitting refresh and re-applying the desired profile changes, makes the situation disappear. So it seems to be intermittent.

I also believe it's already fixed by #33699 but I'm not sure we have understood the root cause, or what is triggering this problem, even without #33699.

Admin's are changing their users password without intent, and users are sending emails to admin claiming they did not ask for their password to change. This hurts confidence in WordPress, and the biggest UX problem in current WordPress (4.3.1).

#8 @swissspidy
4 years ago

  • Keywords close removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Closing as duplicate, as I haven't seen any other reports of this and #33699 seems to have resolved this issue.

Note: See TracTickets for help on using tickets.