WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#34123 closed enhancement (duplicate)

Thumbnails are much larger than the original

Reported by: borekb Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.4
Component: Media Keywords:
Focuses: Cc:
PR Number:

Description

I've uploaded a 950px wide image (PNG) that was 61kB in size.
WordPress created a 690px wide "thumbnail" that was 258kB large.

This wastes my traffic and makes the site load slower for the site visitors if there are more images like this. To makes things worse, WordPress hides those thumbnails from me - I cannot see or manipulate them easily in the backend so I only realized I'm wasting resources quite a bit later.

One possible advantage is that server-side down-scaling might be better than what browser would do but first, this would need to be proven, and second, I don't think 4x as much data on storage and bandwidth and loading times justify it. 4x just feels insane.

Attachments (2)

wpimagesize.zip (312.7 KB) - added by borekb 4 years ago.
Two PNGs + HTML to compare browser scaling vs. WP scaling
screenshot.png (373.8 KB) - added by borekb 4 years ago.
What the HTML file looks like when rendered

Download all attachments as: .zip

Change History (4)

@borekb
4 years ago

Two PNGs + HTML to compare browser scaling vs. WP scaling

@borekb
4 years ago

What the HTML file looks like when rendered

#1 @joemcgill
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Hi @borekb,

Thanks for the report! I believe this may be a duplicate of #30402. If you believe that is incorrect, please feel free to reopen this ticket with more details.

Cheers,
Joe

#2 @borekb
4 years ago

Hi Joe, yes you're right. Hopefully it will be fixed, this is quite bad for bandwidth and front-end performance.

Note: See TracTickets for help on using tickets.