Make WordPress Core

Opened 9 years ago

Closed 8 years ago

#34153 closed defect (bug) (worksforme)

Twenty Fifteen: Menu bug between 976-1193px Win Chrome window width

Reported by: jrgeoffrion's profile jrgeoffrion Owned by: karmatosed's profile karmatosed
Milestone: Priority: normal
Severity: major Version: 4.3.1
Component: Bundled Theme Keywords: has-screenshots
Focuses: Cc:

Description

EXCLUSIVELY when using WIN CHROME browser [Windows 10, Chrome v45.x], THE TOP NAV MENU in the standard twentyfifteen theme, as it appears on my site: [blog.weddingology.com] APPEARS BEHIND THE CONTENT WHEN THE BROWSER WINDOW IS BETWEEN 976 AND 1193 PIXELS. The issue is reproduced at [www.JRGeoffrion.com].

PS: issue does not appear with Windows versions of Firefox, Safari, or Microsoft Edge or with Android Note 3 Chrome.

Attachments (1)

TwentyFifteenDemoBug.JPG (128.3 KB) - added by jrgeoffrion 9 years ago.
Bug as seen on the Twenty Fifteen wordpress site live demo at https://wordpress.org/themes/twentyfifteen/

Download all attachments as: .zip

Change History (15)

#1 @SergeyBiryukov
9 years ago

  • Component changed from Formatting to Bundled Theme
  • Summary changed from [twentyfifteen] menu bug between 976-1193px Win Chrome window width to Twenty Fifteen: Menu bug between 976-1193px Win Chrome window width

#2 @SergeyBiryukov
9 years ago

  • Keywords reporter-feedback added

Hi @jrgeoffrion, welcome to Trac.

I could not reproduce the issue using Chrome 45.0.2454.101 on Windows. Could you add a screenshot?

#3 @jrgeoffrion
9 years ago

Please see below a screenshot from http://blog.weddingology.com where the sidebar rolls into the "hamburger menu" and then goes behind the content of the website. This site has no plugin installed.

http://blog.weddingology.com/images/20151006_screenshotblogweddingology01.JPG

Here is a screenshot of http://www.JRGeoffrion.com

http://blog.weddingology.com/images/20151006_screenshotJRGeoffrion01.JPG

Happy to post additional screenshots from various browsers or conditions if it helps.

#4 @jrgeoffrion
9 years ago

Where you able to reproduce as per my two screenshots?

@jrgeoffrion
9 years ago

Bug as seen on the Twenty Fifteen wordpress site live demo at https://wordpress.org/themes/twentyfifteen/

#5 @jrgeoffrion
9 years ago

  • Keywords has-screenshots added
  • Severity changed from normal to major

#6 @jrgeoffrion
9 years ago

  • Keywords reporter-feedback removed

#7 @jrgeoffrion
9 years ago

Can someone confirm that this bug has been recorded and that a resolution is in the works? If more information is needed, please do not hesitate to let me know.

Last edited 8 years ago by jrgeoffrion (previous) (diff)

#8 @papewas
8 years ago

Hey there, I can confirm the bug, even on the demo. I'm using Chrome Version 47.0.2526.106m for Windows.

#9 @karmatosed
8 years ago

Lets take the theme preview to one side for a moment because that is known to not always show themes correctly.

I just did a test using Chrome on Windows 10 and I am unable to replicate the issue. I totally understand you are seeing an issue so lets try and work out how I can also replicate. First up, what version of Windows are you using?

Could you also try using this site to test: https://twentyfifteendemo.wordpress.com/ and see if you still get the same issue?

What pixels exactly are you seeing it at or do you see it at all of that range?

Last edited 8 years ago by karmatosed (previous) (diff)

#10 @karmatosed
8 years ago

  • Owner set to karmatosed
  • Status changed from new to reviewing

#11 @papewas
8 years ago

May I report:
I'm on Windows 8.1, the exact pixels when the situation happens are between 955px and 1014px - 954px and 1015px are good. There is an element.style (style="position: fixed;") added in the code at 955px, when I comment it out it is solved:

<div id="sidebar" class="sidebar" style="position: fixed;">

Last edited 8 years ago by papewas (previous) (diff)

#12 @jrgeoffrion
8 years ago

I'm on W10. Using the URL provided above, the issue can be viewed in Chrome. Just go to the demo, and resize the window in increment until the bug shows.

Were you able to reproduce?

#13 @davidakennedy
8 years ago

I just wanted to comment to say that I tested with Windows 10 and Chrome 45, 46 and 47 and could not reproduce the issue.

#14 @karmatosed
8 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from reviewing to closed

I am also not able to reproduce so for now closing this as we've really tried to recreate. If anyone can then please show some pictures (video is even better) and ensure you have all other plugins turned off - just incase there is something else at play we aren't reproducing with.

Note: See TracTickets for help on using tickets.