Make WordPress Core

Opened 15 years ago

Closed 15 years ago

#3421 closed defect (bug) (worksforme)

"WordPress should correct invalidly nested XHTML automatically" option breaking microformats

Reported by: conoro's profile conoro Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.0.5
Component: General Keywords:
Focuses: Cc:

Description

The option when enabled is re-writing valid safe XHTML and breaking the markup for hcard and hcard inside hreview.

It is taking:

<span class="reviewer vcard"><span class="fn">Conor</span></span>

and changing it to:

<span class="reviewer vcard"></span><span class="fn">Conor</span>

Obviously the feature can be turned off but it really shouldn't rewrite valid markup. Again, apologies if I should be sticking to the forums for this.

Change History (1)

#1 @Nazgul
15 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

Recently fixed by r5623.

Note: See TracTickets for help on using tickets.