WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 4 years ago

#34317 closed defect (bug) (invalid)

Uploads uploading but not rendering in Media

Reported by: sherrynes Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.3.1
Component: Media Keywords: close
Focuses: administration Cc:

Description

Many users have the same issue - they try to upload an image via "Media" and get an error that simply says, "HTTP error." They and I believe the image wasn't uploading.

But when I checked my uploads folder via FTP, the uploads were there - in all the rendered sizes.

So the HTTP error seems to be in rendering the thumbnail on the Media page and for editing. When switching to "List View," you can see that the image is listed there.

Change History (2)

#1 @swissspidy
5 years ago

  • Component changed from General to Media
  • Keywords close added

Hey there! Thanks for your report and welcome to trac.

IIRC, the "HTTP error" happens when the upload doesn't work correctly, e.g. when it aborted in the middle of an upload or it couldn't save the files. What I can tell from my experience is that this is mostly caused by some server misconfiguration.

Normally, this is something you should report on the WordPress.org support forums. There you'll find lots of threads about this topic.

Please try to following steps so we can make sure this isn't a bug in core:

  1. Deactivate all plugins, switch to one of the default themes.
  2. Increase PHP memory limit by defining define('WP_MEMORY_LIMIT', '64MB'); in your wp-config.php file. Also try a higher value, like 128MB.
  3. Check mod_security settings
  4. Ask your hoster for help.

See also: #22869, #28233, #20936

#2 @swissspidy
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.