WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#34337 closed enhancement (duplicate)

New filter: `alloptions`

Reported by: sebastian.pisula Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Options, Meta APIs Keywords: has-patch reporter-feedback
Focuses: Cc:

Description

Filter for all options

Attachments (1)

34337.patch (604 bytes) - added by sebastian.pisula 4 years ago.

Download all attachments as: .zip

Change History (6)

#1 @swissspidy
4 years ago

  • Keywords has-patch reporter-feedback added

Hey there

Thanks for the report and the patch. Can you elaborate a bit on why this filter is needed/useful? What's the use case?

#2 @johnbillion
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

@sebastian.pisula Thank you for your recent tickets and patches. You do need to provide more information with each ticket though, particularly why the filter is needed. Please provide some more information on ticket #33958 which you opened a few weeks ago.

#3 @sebastian.pisula
4 years ago

for example ACF Pro, options page. when I use get_field('field', 'options'); then I send request to MySQL for each get_field. I will be can use filter to merge Options and I will be use get_option to get Options From ACF Options Page.

#4 @sebastian.pisula
4 years ago

  • Resolution duplicate deleted
  • Status changed from closed to reopened

for example ACF Pro, options page. when I use get_field('field', 'options'); then I send request to MySQL for each get_field. I will be can use filter to merge Options and I will be use get_option to get Options From ACF Options Page.

#5 @johnbillion
4 years ago

  • Resolution set to duplicate
  • Status changed from reopened to closed

Duplicate of #33958.

Note: See TracTickets for help on using tickets.