WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#34342 closed defect (bug) (fixed)

Menu Customizer: Large space above delete button

Reported by: pavelevap Owned by: afercia
Milestone: 4.4 Priority: normal
Severity: normal Version: 4.3
Component: Customize Keywords: has-patch
Focuses: ui Cc:

Description

See attached screenshot. It is probably caused by hidden spinner...

Attachments (2)

Menu_Customizer_delete_button.png (46.1 KB) - added by pavelevap 4 years ago.
34342.patch (839 bytes) - added by dipali.dhole27@… 4 years ago.

Download all attachments as: .zip

Change History (9)

#1 @afercia
4 years ago

  • Focuses ui added
  • Version changed from trunk to 4.3

Can confirm it's a hidden spinner. Any translated strings longer than the English ones will probably trigger this "float drop":

https://cldup.com/15cfF3xHSx.png

I'm not even sure why there's a spinner there in the first place.

#2 @xavortm
4 years ago

I think the way it is now is better, since when the spinner becomes visible it wont jump down + there is better separation for different action areas (add and delete)

#3 @afercia
4 years ago

  • Keywords needs-patch added
  • Milestone changed from Awaiting Review to 4.4

Couldn't find any workflow where this add-menu-item-loading spinner is actually used and gets visible. Maybe it should be simply removed? cc @ocean90 @celloexpressions

#4 @westonruter
4 years ago

@afercia right, I think the add-menu-item-loading spinner is for some legacy code for when originally an Ajax request was needed when adding a new menu item. Now, however, it is all handled in Javascript so there is no need for a spinner when adding a new menu item since it is instant.

#5 @dipali.dhole27@…
4 years ago

  • Keywords has-patch added; needs-patch removed

@afercia , @westonruter: I browsed through the site files and found that the mentioned hidden spinner is not being used anywhere. Also, as mentioned by @westonruter that we do not need the hidden spinner any more. Below I am attaching the patch for the same with the hidden spinner removed.

This ticket was mentioned in Slack in #core by afercia. View the logs.


4 years ago

#7 @afercia
4 years ago

  • Owner set to afercia
  • Resolution set to fixed
  • Status changed from new to closed

In 35396:

Customizer: Remove the no more used add-menu-item-loading spinner.

Also makes more room for longer translations.

Props dipali.dhole27@….
Fixes #34342.

Note: See TracTickets for help on using tickets.