WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#34349 closed enhancement (duplicate)

embedded doesnt work when dom element is directly after it

Reported by: ivomasterche Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Embeds Keywords:
Focuses: Cc:

Description

When i insert youtube url and have closing element for example

</div>

It seems to concatenate it to the youtube link, and the link is not converted to embedded video.

Example

<div class="right"> https://www.youtube.com/watch?v=1uvwGmRf5M8 </div>

doesnt play the video if i add 2 lines (double press enter or add text after the opening and before the closing tags it works

I believe there should be some check that detects html tags and splits them from the url before trying to convert it to video (in this case)

Change History (3)

#1 follow-up: @swissspidy
6 years ago

  • Component changed from Editor to Embeds
  • Type changed from defect (bug) to enhancement
  • Version 4.3.1 deleted

Not a bug, but currently expected behaviour.

#2 in reply to: ↑ 1 @ivomasterche
6 years ago

Replying to swissspidy:

Not a bug, but currently expected behaviour.

Ok, i agree, but i doubt that this is what the user intends. Since WP editor removes spaces and does this "behind the scenes" its not easily understandable why the url doesn't change to embed item.
I want to use HTML and URL and for me its obvious that the HTML is not part of the URL why would Wordpress thinks that they are one thing?

#3 @swissspidy
6 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #25387.

Note: See TracTickets for help on using tickets.