WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#34469 closed defect (bug) (duplicate)

Media files do NOT un-attach from posts

Reported by: marikamitsos Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.3.1
Component: Media Keywords:
Focuses: Cc:
PR Number:

Description

The situation is really very common.
We create a post. We attach an image. We save the draft or publish right away. We view the post and the image is there. We take a look at the library screen. The image is attached to the post. Correct !

Now.
We go back to the post and edit it. We remove the image from the post. We save/publish the post. The image is not there any more. We go back to the library screen and load again. The image is STILL attached to the post when it shouldn't. Bug ?

Furthermore.
If we are now to permanently delete the image from the library screen, should we first un-attach it and then delete it?
If we just go and delete it without un-attaching it first, will we end up with "leftovers" in our database?

Change History (1)

#1 @SergeyBiryukov
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

We remove the image from the post. We save/publish the post. The image is not there any more. We go back to the library screen and load again. The image is STILL attached to the post when it shouldn't. Bug ?

An image attached to a post does not necessarily have to be present in its content, see comment:7:ticket:27983.

If we just go and delete it without un-attaching it first, will we end up with "leftovers" in our database?

No, it's safe to delete without detaching first.

Closing as a duplicate of #27983.

Note: See TracTickets for help on using tickets.