WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#34509 closed enhancement (fixed)

Permalinks wording is incorrect

Reported by: dmccan Owned by: johnbillion
Milestone: 4.4 Priority: normal
Severity: normal Version: 4.2
Component: Permalinks Keywords: has-patch
Focuses: administration Cc:

Description

Testing 4.4 beta 2 and saw some permalink oddity. Downloaded 4.3.1 and did a fresh install of 4.3.1 and on another site a fresh install of 4.4 beta 2 using the WordPress Beta Tester plugin. Went to Settings / Permalink Settings and on both see the default permalink structure as "Day and name".

I am installing on Windows localhost. I unchecked allow search engines to index site when installing.

Attachments (3)

34509.patch (1.3 KB) - added by Ankit K Gupta 5 years ago.
patch file
34509.1.patch (2.5 KB) - added by juhise 5 years ago.
34509.2.patch (4.2 KB) - added by johnbillion 5 years ago.

Download all attachments as: .zip

Change History (22)

#1 @SergeyBiryukov
5 years ago

  • Component changed from General to Permalinks

#2 @johnbillion
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

This is intended behaviour since WordPress 4.2. See #6481.

#3 follow-up: @dmccan
5 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened
  • Summary changed from Permalinks defaulting to Day and name to Permalinks wording is incorrect

Ah. I did not realize there was a change. I notice that the wording on the page does not reflect the new default:

  1. The instructions at the top say "By default WordPress uses web URLs which have question marks and lots of numbers in them ...", but that no longer reflects the new default. It should say "By default WordPress uses web URLs that have the day and name in them ... ".
  1. The first item in the list says "Default" but it is no longer the default. I understand that in some regards "default" = "unaltered", but perhaps instead of "Default" it would be clearer to say "Plain". Plain seems to be used to describe basic URLs and indicates that it is not a pretty or "aesthetic" URL.

Thanks

#4 @afercia
5 years ago

  • Focuses ui added
  • Keywords needs-patch added
  • Milestone set to 4.4
  • Version changed from 4.3.1 to 4.2

I'd recommend to consider to update the text to reflect the new default. It should mention that Pretty Permalinks are enabled only if the server supports it. The Codex page should be updated too:
https://codex.wordpress.org/Settings_Permalinks_Screen

#5 in reply to: ↑ 3 ; follow-up: @Ankit K Gupta
5 years ago

I am agree with @dmccan, if 'Day and Time' permalink is default then it should be clearly show on page. Current scene is creating confusion.
Created patch for the same.

Thanks

@Ankit K Gupta
5 years ago

patch file

#6 @Ankit K Gupta
5 years ago

  • Keywords has-patch reporter-feedback added; needs-patch removed

#7 in reply to: ↑ 5 @juhise
5 years ago

  • Keywords needs-patch added; has-patch reporter-feedback removed

The above description text should also be updated, I have updated the text. Instead of 'Plain', 'Post ID' will look more relevant.

@juhise
5 years ago

#8 @Ankit K Gupta
5 years ago

  • Keywords needs-patch removed

#9 @johnbillion
5 years ago

  • Focuses administration added; ui removed
  • Type changed from defect (bug) to enhancement

So WordPress actually has two defaults now. If the server supports URL rewriting (for example via mod_rewrite on Apache) then the day and name permalink structure is used. If not, the permalink structure we currently refer to as default is used.

To simplify this, any reference to a default should be removed. The default has no relevance, after all.

@johnbillion
5 years ago

#10 @johnbillion
5 years ago

  • Keywords has-patch added

#11 @johnbillion
5 years ago

34509.2.patch changes 'Default' to 'Plain', and removes other unnecessary references to a default permalink structure.

#12 follow-up: @DrewAPicture
5 years ago

@johnbillion Not sure about "Plain". What do you think about "Generic" instead? Otherwise, looks good to me.

#13 @wonderboymusic
5 years ago

  • Owner set to johnbillion
  • Status changed from reopened to assigned

#14 @DrewAPicture
5 years ago

  • Resolution set to fixed
  • Status changed from assigned to closed

In 35599:

Permalinks: Rename the "Default" permalink structure to "None" as permalinks have been enabled by default (where supported) since 4.2.

Updates help tabs and contextual text to match.

Props johnbillion, DrewAPicture.
Fixes #34509.

#15 @pavelevap
5 years ago

Maybe there should be context for "None"? Because translation can be different for current string "None" (for setting alignment for image) and "None" as a permalink settings...

This ticket was mentioned in Slack in #core by ocean90. View the logs.


5 years ago

#17 @DrewAPicture
5 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

#18 @DrewAPicture
5 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

In 35604:

Permalinks: Use "Plain" instead of "None" for the ?p-###, which is still a valid permalink structure, just not a "pretty" one.

Permalinks are enabled by default (where supported) since in 4.2. When that change was made, it rended the "Default" label (previous to [35599]) inaccurate.

Props Ankit-K-Gupta.
Fixes #34509.

#19 in reply to: ↑ 12 @SergeyBiryukov
5 years ago

Replying to DrewAPicture:

@johnbillion Not sure about "Plain". What do you think about "Generic" instead?

How about "Short"? Get Shortlink button was hidden by default in [34556], but if we call them shortlinks in one place, we could as well do it here.

Note: See TracTickets for help on using tickets.